Resurfaced old version duplicatenote data added but random

Steps to reproduce

I cannot tell you exact steps because the problem is is only intermittent. It is basically the same thing as listed here" duplicates in note

I cannot disble all third part plug-ins and produce the error because I can never tell when it will occur and I use the plugins daily.

In my case I am running Obsidian on 3 Macintosh systems, an iPhone and an iPad. I am using Obsidian sync.

Ocassionally I will be editing a note and I discover that in addition to the most current contents, I will have the entire note from a previous edit time in the past included at the bottom of the existing note.

I cannot always just delete the stuff below the end of the top version because sometimes I don’t figure this out and there is stuff that has to be saved from both versions.

So far I have only had a single extra copy although previous reports of this problem indicated tha tsometimes multiple copies would be in the note.

Expected result

I expect that I will never see old content duplicated into the bottom of an existing note even when the old content is a previous incarnation of the note I am working on.

Actual result

As I said irregular and sporadic duplicated data from an old version of the note inserted int the bottom of the note and no way to cause it to happen regularly that I can find.


  • Operating system: MacOS X, I have 2 machines on Catalina10.15.7 (19H2026) and 1 machine on Maverick. iPad OS 15.6 on a iPad Pro and iOs 15.6.1 on a iPhone 13 Pro
  • Debug info:SYSTEM INFO:
    Obsidian version: v0.15.9
    Installer version: v0.15.6
    Operating system: Darwin Kernel Version 19.6.0: Tue Jun 21 21:18:39 PDT 2022; root:xnu-6153.141.66~1/RELEASE_X86_64 19.6.0
    Login status: logged in
    Catalyst license: supporter
    Insider build toggle: off
    Live preview: off
    Legacy editor: off
    Base theme: light
    Community theme: Oogie
    Snippets enabled: 2
    Restricted mode: off
    Plugins installed: 30
    Plugins enabled: 20
    1: Citations v0.4.4
    2: Tag Wrangler v0.5.3
    3: Dataview v0.5.46
    4: Hotkeys++ v0.2.7
    5: Kanban v1.3.20
    6: Smart Random Note v0.2.1
    7: Calendar v1.5.10
    8: Tasks v1.13.1
    9: Natural Language Dates v0.6.1
    10: Review v1.6.4
    11: Periodic Notes v0.0.17
    12: Templater v1.14.2
    13: Style Settings v0.4.11
    14: Advanced Tables v0.17.3
    15: Obsidian Charts v3.6.3
    16: QuickAdd v0.5.5
    17: Contextual Typography v2.2.4
    18: Sliding Panes (Andy’s Mode) v3.3.0
    19: Readwise Official v2.0.1
    20: Zotero Integration v2.2.24

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Unlike some of the previous versions of this issue I do NOT have daily notes opening on startup.

I have updated all my community plug-ins and am running the latest versions

The Daily note problem was handled.

The only case where what you describe can happen is if the same (or similar) part of this note where generated independently on two different devices without a sync in the middle.

For example the note was generated from a template separately in multiple devices.

The note where this just happened again is a very old not, basically a MOC that replicated my old reference file Fo;der names as headers and the documents as links. It’s bee in my vault in one form or another since I started with Obsidian. It was not a generated note from a template.

I typically use my iOS devices and 2 of the 3 macs as read-only and try to limit my editing to one machine. SO not exactly the situation you describe. All 3 macs are on the same wifi netowrk so should be syncing relatively fast.

In my experience, iPhones would resolve Templater syntax when syncing a vault. I am unsure why, as it doesn’t do that on Android devices, but this may also be happening to you.

Not sure I understand how this applies. The notes where i’ve seen it happen were never created using a template so why would templater even be involved?

If when it happens again, make a screenshot of the sync logs of all devices involved and send an email to [email protected]