Renaming doesn't update links in one file

What I’m trying to do

I renamed a file in Obsidian and that updates all links in other files except one. In that one file, no links get updated. I tried renaming other files and linking them to check. Interestingly, I was able to see that it only happens within a copy-pasted text sections of the file. Outside of the text section, the links get updated.

As this is a strange behaviour, I want to report it so either someone can guide me to a fix or, if it is a bug, I can help out the developers by reporting it.

Things I have tried

I tried seeing if my appimage is the latest. seeing any errors in terminal. Updating electron (25) and node (20).
I tried searching this forum and google searching other sources to see if anyone faced similar issues as me. I only found one who faced something similar to me (Renaming doesn't update the links to it) but I don’t get the error they get and there is no solution mentioned.

It is important to note that I do get an error in terminal when I start/run Obsidian appimage:

[49:0820/] GetVSyncParametersIfAvailable() failed for 1 times!
[49:0820/] GetVSyncParametersIfAvailable() failed for 2 times!
[49:0820/] GetVSyncParametersIfAvailable() failed for 3 times!

Though the Obsidian application has been working normally (and looking into the electron-github issues channel, this error may be related to electron and doesn’t stop people from using the application that outputs this error.

  1. Do you have any other note with the same name?

  2. Do you use cloud service for syncing like e.g. OneDrive?
    Sometimes syncing is broken when you use second device before syncing is complete.
    It will produce second note with the same name + word “conflict”.

  3. Have you tried (backup before delete!) delete existing note and then create new one by cliking wikilink “[[NoteName]]”?

No, there is no other notes with the same name.

I haven’t used any cloud service for syncing though I did back up in github when I was switching devices.

what’s wikilink “[[NoteName]]”?
if you meant creating a normal new note, I just now tried creating a new note with a different name but copy-pasted the same content and it had the same weird result; the links didn’t get updated in the bullet points of the new note.

I wonder why the links are acting weird in these particular bullet points…

what’s wikilink “[[NoteName]]”?

Wikilink is just another name for link. Thing between square brackets [[...]].

Proposed solutions:
4. Did you follow the troubleshooting guide?
Maybe some plugins make trouble.
5. Try to enable Backlinks plugins
path: Settings/Core plugins/Backlinks
Click backlink (it should show at the bottom of your note).
6. Try to manually check what line cause problem (delete line and refresh).
7. Probably it isn’t Obsidian issue but Elecron issue:
Try to disable hardware acceleration : add app.disableHardwareAcceleration() to your Electron main.js.

I am sorry about the late reply here. I am kind of crammed right now but I will definitely try out your suggestions and update here once I get free… Thank you for your suggestion!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.