Published vault notes have duplicate titles

Things I have tried

I have searched everywhere for information about this problem. No luck.
I have enabled all the “components” of the publish plugin, but have left everything else alone. I even tried it with sliding panes OFF.

See below for a couple of examples.

Based on the “note for free speech”, I believe it is the second instance of the note title that just shouldn’t be there and in fact isn’t there in the markdown, which FYI looks like this:

This is a modified [[Blog Archive|archived blog post]].
# A Note on Free Speech

Posted to Medium 26 August 2018.

As they say, with great power comes great responsibility. [[Free Speech|Free speech]] is one of the greatest powers we grant to one another. Misuse of that power is therefore one of the greatest crimes, and should be treated as such.

What I’m trying to do

I’d just like to publish my vault without the duplicate titles.

Can someone even suggest how to go about diagnosing it?

It’s using the note (file) name as the title. That would be the first occurrence, and the second one would be the one that you put in the Markdown (look again — the second one is between “This is a modified” and “Posted to”, right where you put it).

Aw, nuts, @CawlinTeffid, you’re right. Dunno why I didn’t notice that myself.

Okay, well, now I guess I get to take out all the page titles in all my notes.
Fair enough.

Thanks for the fast response.

Eh, sometimes the brain overlooks things. I had to fix a “the the” typo in my response.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.