Proxy setting

This answer is not helpful.
If he has a real proxy like me, the system knows only IP and Port. The next question the proxy has will be: Username and password please! That’s the point where the knowledge of “your OS” ends.
So there is neither a questioning dialog from obsidian nor somewhere a good answer.

Password management of the proxy setting also depends on your OS. You can google it on how to do it for windows and mac.

Enter proxy server settings on Mac - Apple Support.

Sorry, WhiteNoise, you don’t get the topic here. What you are talking about are system settings and playing-around-pseudo-proxies.

It is not sense of this kind of proxy (we are talking here about) to ask systems for passwords… So what would such a proxy be good for?!
If you provide the system with the password, everything on right this system get’s through it. No further asking, because system does it and knows everything.
The sense of such a proxy is that what want’s to get through has to be authenticated! Everything! And yes, it sucks to authenticate the whole day… Of course the admin can set exceptions for windows update. But that’s it! If you want browse - authenticate! If you wan’t see templates in MSO - authenticate! If you wan’t obsidian to go into the internet… yes, where is the authenticate dialog or at least a setting for it?! Nowhwere! That’s the point we are talking about here.
And yes, you can set exceptions in your settings. And yes you get fired for that. Period.

1 Like

Just as what I said, I’m working in a restricted network environment, which means I can connect to internet throgh some special ports. Meanwhile, my PC should keep in private network. That’s to say, if I change the global proxy setting, I will not able to connect to private network servers. What I ask for is something like Telegram style proxy setting. This provides more options that I can choose use whether autoor manual proxy setting. :smile:

It does not appear to do so for me, because I have this problem too. The app will check for updates properly, but if I try to activate my commercial license it goes into a black hole and never responds. This is almost always a sign that Obsidian is not honoring proxy settings.

None of the answers in the Microsoft article you linked to work in an environment where you don’t have admin access on your computer. This is most likely to happen when using Obsidian in a commercial environment as I am. I can’t change the proxy settings, they are locked down by my company.

Most apps deal with proxy servers just fine, as long as I don’t need a username and ID to authenticate. I do need those here, and cannot perform the steps you mentioned because I don’t have admin access. There is something different about the way Obsidian checks for updates vs. the way it connects to my account. That is the problem. Any ideas on what that may be? Because until I fix that, I have a commercial license that I cannot apply.

Folks, I think you are conflating here different types of access control and call them proxies.

@ccrayton Just double checked, activate commercial license also goes through the system proxy. Is it possible that your system proxy blocks obsidian/github?
Check for updates has a fallback location.

@Lymo all these things can be configured in the system proxy

If there is a need for Popup window that asks for username and password to access the network all the time, open a feature request for that. This type of filter may be a router-level authentication on IPs and have nothing to do with a proxies.

Please, do not ask to actively try to bypass your company security policies.

Disclaimer: My boss knows what i am doing and wrote down that i am allowed to do this. So be sure, if my usecase matches yours, that you are allowed too.

So guys if you are as lucky as me and your proxy is set by IP and Port in your internet options (old IE dialog like in the image above from WhiteNoise) then your Obsidian will work by setting the following exceptions:

Today i sat at a firewall (packetfilter) and watched all connections Obsidian opened. These three are that ones my Obsidian started fully working now:
Sync, browse/install Community-Plugins and Themes, get Update, activate Commercial license and so on…

There could be a little bit more if you want to view “buymeacoffee”-Images while you explore the plugins but this is something you can do at home.

Hope this helps at least a few people and again: I am allowed to set this exceptions.

Best regards

1 Like

Update: Only ten days later, right after upgrade to v12.5, it does not update any plugins or itself anymore with that settings… So my last answer is “old” by now.

Same problem here. Update works, everything else seems to be blocked (browsing community plugins, activating commercial license, etc).

Here’s what I get on the console:


The same URL is accessible in Chrome.

Here’s the problem:

<i class="a_i"></i>
Sorry, this web browser is not approved for use at our company.
<tr><td class="hr"><hr></td></tr>
<tr><td class="eu_co rsn">
Not allowed to use the browser: Google Chrome (89.x)

I fixed it by uninstalling and then reinstalling Obsidian from the newest release installer. The internal updater probably doesn’t update the underlying Electron instance, but only the Obsidian modules.

I think it is quite common that we cannot route the whole system traffic through a proxy. We can only route a certain app. Like in Chrome, we can use SwitchyOmega. The point is, Obsidian cannot access some websites/APIs that requires a specifically configured network proxy; if we re-route the whole system through the traffic, Obsidian will work, but some other features will be unusable (like intranet/LAN services).

So if Obsidian can provide such proxy config in settings, that will be SO good!

You can set the no_proxy environment variable to exclude certain hosts/IPs from being routed through the proxy. But yes, it would be better if Obsidian would allow per-app configuration.

Thank you for the suggestion! I’m still getting the same error after an uninstall and reinstall.

Where did you find the Not allowed to use the browser: Google Chrome (89.x)? I’d like know if I am having the same issues.

Any suggestions on how to force an update of the Electron instance? Any other ideas?

Reinstall should do the trick. It’s probably a different problem then. You can check the console in developer tools which you can open via Ctrl-Shift-I. You’ll spot the error if there is one. The error message can be found in the response text.

Thank you the suggestions. Your suspicion is correct that it’s a different issue. I think I may be stuck for now.

My best guess is this is related to ZScaler being added to my work machine, but I don’t have access to change settings for it. Damn.

I’m getting a mix of 403 (Forbidden) errors and WebSocket connection to ‘wss://’ failed. For the 403’s, I can navigate to those urls via browsers without issue.

A technically possible solution: install a OpenWrt virtual machine on your PC, and redirect all your network traffice to openwrt. Then you can control very detailed routing rules through openwrt.

The issue for the users here is that they are using locked down computers at work. If they don’t have access to system’s proxy settings (which obsidian uses), they likely can’t install a virtual machine and redirect the traffic there either.

From my understanding, op’s problem is if he change system’s proxy setting he will lose connect to private network. This can be fixed by setting up detailed routing rules, which windows don’t allow. So you need a openwrt, or other router system. Furthermore, you can hack your router with openwrt or something like ASUS Merlin, which can solve almost everyhing related with proxy, regardless wether you have control on your PC.

Or you can try something like SSTap or netch, the are more lightweighted, but lack maintenance right now.

1 Like

you can set up exclusion in the system proxy config