Properties automatic list disabled option

What I’m trying to do

I would like to make the inputs stay in 1 line, not entering new lines, like this 2023-11-09_00.22.35_CSX

Every time I edit something in Property (enter new input or add new property), it spreads every input into list like that 2023-11-09_00.22.16_CSX

How can I disable this automatic list expansion ?

Things I have tried

Nothing works unless I’ll never edit anything.

Obsidian settings > editor > properties in document > visible

I don’t know why it says document instead of note but ok.

@Missionary If you touch the Properties UI at all, those will be reformatted as an array like that.

Settings > Editor > Properties in document set to Source and don’t touch or hide the Properties UI in Reading view with CSS ?