Pressing Home while editing a right side of a wide table in the Source mode doesn’t move the cursor to the start of the line

Steps to reproduce

  1. Create a wide table that goes beyond the width of current tab/column
  2. Set the cursor in the string, press End once: the cursor with jump to the visible end of the text
  3. Press End twice: the cursor will jump one column width further, until the true end of the live is reached
  4. Now try to press Home: the cursor will jump to the start of visible text, but pressing Home again won’t make the view to scroll to it. Sometimes the cursor won’t even go visibly go there as well.

Did you follow the troubleshooting guide? [Y/N]

Yes, I tried it with the default theme, within the sandbox, and with disabled snippets.

Expected result

I expect Home to work and to move my view to display the current position of it.

Actual result

Currently only End works the way it makes sense. Editing long table in Source mode is painful.


Obsidian version: v1.5.4
Installer version: v1.4.13
Operating system: Windows 10 Pro 10.0.19045
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: off
Base theme: dark
Community theme: none
Snippets enabled: 7
Restricted mode: off
Plugins installed: 32
Plugins enabled: 14
1: Minimal Theme Settings v7.3.1
2: Recent Files v1.3.10
3: Settings Search v1.3.10
4: Quick Explorer v0.2.8
5: Omnisearch v1.21.1
6: Style Settings v1.0.7
7: Footnote Shortcut v0.1.3
8: Home tab v1.1.2
9: Linter v1.22.0
10: Sort & Permute lines v0.7.0
11: Emoji Shortcodes v2.2.0
12: Easy Bake v1.0.5
13: Dynamic Highlights v0.3.1
14: Advanced Tables v0.21.0

Is it this?

It is. Links or not links — doesn’t matter.
Thanks for finding it! I failed in my search (and I honestly tried).
Please merge these two.

A post was merged into an existing topic: Home key does not go to the beginning of the line in tables with long rows