Pressing "enter" with "Smart indent lists" off does not create an empty new line

I previously posted a bug report about a Vim mode new-line problem here, but I just found out that this is not only for Vim mode. Actually it’s a generic problem for adding new lines, as it’s also there without vim motions even enabled.

Posting here with steps to reproduce without Vim mode.

Steps to reproduce

  • open sandbox vault
  • go to settings and disable “Smart indent lists”
  • create new file
  • add the following content
- foo
	- bar
  • move cursor behind the word “bar”
  • press the return key

Did you follow the troubleshooting guide? [Y/N]


Expected result

I expect either a new totally empty line:

- foo
	- bar

Actual result

Instead, I get a new line with a single space (which messes up alignment):

- foo
	- bar

(space is invisible, but you can select or copy the text to see what I mean, or try for yourself)


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Darwin Kernel Version 22.4.0: Mon Mar 6 20:59:28 PST 2023; root:xnu-8796.101.5~3/RELEASE_ARM64_T6000 22.4.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on