Permanently lost of connections after updating to 0.9.17

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

I have updated 0.9.17 and found my graph view became like below, all the second level of connections were disappeared

I have backed up my vault and the previous graph were like

I have tried to reverse back to 0.9.2 and the connections won’t recover. I have also tried to delete custom css and plugin but it didn’t work .
so updating to 0.9.17 must changed some files in the vault that caused the connections in the graph view disappeared

Expected result

graph view with connections

Actual result

connections in graph view disappeared


  • Operating system: windows 1903
  • Obsidian version:0.9.17

Additional information

Is this your local graph view? What depth settings do you have on?

Can you show us the content of a a few files that should should be connect but are not?
Use 0.9.17 no thirdparty plugins and default css.

I have created some test files and they are also not appearing in the graph view, It supposed to have a chain to link test1 test2 and test3


I have closed all the third party plugin(actually i just have andy mode installed before), and I have restore the graph view to the default settings

can you show us these 3 files and the graph? you can use a screen recording like screen2gif

I have upload the gif, but it didn’t appear
to make graph view more clear i lower the text fade threshold
the static images:

i restored the graph setting , and my previous vault that i backed up half a month ago don’t have this problem

I can’t see, what is the content of file test1?

And what are your filter settings?

there is another thing I want you to try.

  • Close obsidian.
  • MOVE (not just copy) the files in this dir C:\Users\<username>\AppData\Roaming\obsidian\ObsidianCache to the desktop
  • create a zip file of these file and send it to us

Restart Obsidian.


thanks for your efforts.
After you have created the zip. You can upload it here, send to us on discord, or upload on some online service like dropbox. I wanna have a look at it.
It’s likely that after you remove the cache files. It will start working again. (9.6 KB)

I think there is some filename in your vault that is creating problem to our caching algorithm.

i have tried to completely delete all the obsidian related in my computer including this cache file, but the vault i have being using when the obsidian autoupdated to 0.9.17 don’t have any secondary connection in the graph view and connection for new note generated. the graph view for my older vault that i backed up early on still works fine

Do you see errors in console? (ctrl-shift-i) ?

If you are comfortable, can you send us a zipped copy of your vault? either post a link and then delete it or on discord in private chat

early on i think some of my .bat files in the vault that causing the problem, but after i remove the file, the graph view didn’t come back

the console is the second tab.