Pdf Export Changed Fonts on Me

I’ve been using pdf export and it has been exporting using the existing font in my editor, which is exactly what I want. No pandoc…just straight to pdf and works great.

But yesterday, when I exported to pdf, it changed to a completely different font.

I am using minimal theme. Any ideas? Thanks

macOS and recently updated?

  • macOS: “Print to PDF” will now use Inter by default to fix the issue where copying and pasting text in the generated PDF would appear reversed.
1 Like

Also see →

1 Like

Ventura 13.2.1 (22D68)

And yes, recently updated.

I’m not a technical guy. I read through the posts you recommend. I’m gathering that my OS updated broke this and that there is no fix currently. Correct?


Same for me, recently updated to Ventura and seems to have stopped pdf exporting in my desired font. Would be interested to know if this gets resolved.

1 Like

I don’t export to PDF from Obsidian, so I am not in a good position to be able to help with a solution. The post linked below offers a way of styling a PDF with a css snippet. My assumption would be that you could use that snippet, changing the font to whatever you choose.

If it doesn’t work, hopefully someone else will be able to offer a solution.

EDIT: In a quick local test, the snippet below does work to change the font used in PDF exports.

1 Like

Thanks for checking! :smiley:
I figured it would work, but was taking a PDF vacation :face_with_spiral_eyes:

…and with the Minimal and AnuPpuccin themes (the only two I tested), custom Style Settings h1~h6 fonts are respected in the export. Yay!

This works if you use a different theme or one that doesn’t have Style Settings options. Add h2~ as necessary. !important is not an option here.

@media print {
  body {
  --font-text: 'Baoli SC' !important;
  h1 {
  font-family: 'SFMono-Regular' !important;
1 Like

I was being lazy in not testing it before I posted, and then I felt bad about potentially leaving the OP with half an answer and so thought I should give it a whirl. Worked perfectly, of course, in my local test … though we all have so many different setups and parameters that it might (I guess) work a little differently in another user’s vault.

Nice addition with the latest snippet. Will be useful for others. Appreciate the share. :clap: :smile:

1 Like

Thank you. I changed the font in the snipped to my preferred font (Charter) and it worked. Best…Ray


I am having the same issue. can someone help me please?

Things I have tried

What I’m trying to do

New user - just completed a project. Export to PDF has been fine, I tweaked the margins a bit.
Today - Obsidian updated - and now when I export to PDF my fonts are all different. I was just using/getting Calibri, but it’s a mix now and the only thing different is the update.
Is anyone else experiencing this? Thanks for patience with a noob.

Hi there, I am also experiencing issues with the export to PDF function. I am a Mac user and ever since 1.15, whenever I export to pdf my fonts are changed from Baskerville to some type of Sans Serif Font and my footnotes are messed up. Has anyone found a solution to the Export to PDF not working on Mac since 1.15?

Same here.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.