Outline does not show headings

New user, migrating from Roam. A long migrated page with multiple headings shows “No headings found” in the Outline. I redid several of them in the Editor, but no go. Should be dead simple, but the Outline is empty.

Any idea what I’m doing wrong?

@Gone_South we might need an example/screenshot to help you debug. If I were to guess, you have a bullet before your header (which are not supported). The markdown specification means your headings need to be at the start of the line, so if that’s the case you’ll need to remove the bullets from your headings and unindent.

I’m moving this to “Resolved help” since there hasn’t been no replies for 3 days. Let me know if you have further questions, in which case we can move it back.

Thanks for understanding!

I had same issue.

In my case, only numeric documents worked fine.

1 Like

This problem still exists, my outline is empty.

Same problem here, then I solved it by moving non-heading lines before the first heading.

Basics

(For anyone like me cannot find the outline button)
If you search “Table of content”, “Outline”, “sidebar” you should refer to this section.

On Mac, use CMD+, to open the preference window quickly.
Search “outline” in core plugins and toggle it to enable outline.

steps to solve the problem

As @argentum mentioned, the first line of the document must be a level 1 head, or start in the form of “# xxxx”.

Before modification

The variable and functions have to be handled separately. (first line of docu.)

# Basic conception
A device variable is a symbol seen by the host.

After modification

# Basic conception (first line of docu.)
The variable and functions have to be handled separately. 

A device variable is a symbol seen by the host.

After modification, the outline is still empty.

Disabling then enabling “outline” does not solve the problem.

Closing the document then reopening it solved the problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.