"[Outgoing Links]->[Unlinked Mentions]" Not detecting outgoing unlinked mentions

Steps to reproduce

  • Open Obsidian
  • Create note “Note_X”
  • Create note “Note_Y”
  • In “Note_X”, type “Note_Y”

Expected result

  • “Note_Y” should appear in: [Note_X] → [Outgoing Links] → [Unlinked Mentions]

Actual result

  • Nothing is displayed in [Note_X] → [Outgoing Links] → [Unlinked Mentions] , it says there are 0 unlinked mentions.

Environment

  • Operating system: Windows 10
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.13.23
    Installer version: v0.13.23
    Operating system: Windows 10 Home 10.0.19042
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: off
    Plugins installed: 0
    Plugins enabled: 0

RECOMMENDATIONS:
none


Additional information

I asked this question in Discord but haven’t found a solution yet.

works for me. Post a screen recording of this happening in the help vault.

It works in the Help Vault, but not on my personal Vault:
Animation

I found the cause of the problem: I have a note whose title is “Constructor” (I’m building a conceptual map, and “constructor” is one of the concepts that I created), its mere presence in my vault causes the “outgoing links” plugin to crash.

I reproduced this in the Help Vault:

contrctr

Does anyone know WHY the presence of a file called “Constructor” causes this issue?

wow that is funny buggy. we’ll fix it.

I noticed something else: the same problem occurs when the note has an alias called “constructor”.