OS-level autocorrect in macOS

We strongly recommend you to search the forum with possible keywords before making a new feature request. If your request is very similar to an existing one, consider liking it and/or making a comment rather than making a new one. Once you’ve searched and determined that this is a new request, delete this line.

Use case or problem

Mistyped words are underlined (spellchecked) but not auto-corrected.

Proposed solution

Autocorrect words as we type - as available system-wide in macOS.

Current workaround (optional)

As an author, sadly, I’m forced to use other writing apps - which all have autocorrect - for drafting, even while using Obsidian to keep my notes organized. I’d love to be able to use Obsidian and nothing more. The lack of autocorrect is what’s stopping me from paying for Sync.

Related feature requests (optional)

n/a

9 Likes

Moving this to Help. It works fine for me.

Try the troubleshooting steps first (linked below). Make sure things are updated. Including your installer, plugins, and themes. Try without plugins. Try without CSS snippets.

Feel free to post your “Show Debug Info” for people to look at, to try to help.

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too.

1 Like

I am also experiencing this issue. Version 1.4.14 (Installer 1.4.12), restricted mode on. macOS 14.

I’m not sure Obsidian has ever had native macOS autocorrect, which includes things like auto capitalization, auto replacement of misspelled words, double-space for period, etc. These features have been standard in macOS for a long time, and in macOS 14 they were expanded to include text prediction.

I would love to see Obsidian support these features.

4 Likes

Hi, sorry, but I don’t think you’re understanding the issue.

Autocorrect IS NOT SUPPORTED IN MACOS, and we would like to see it supported.

2 Likes

Sorry, I’m confused by what I don’t understand. At least a subset of autocorrect is working. It works for me.

autocorrrrect

But again, like I suggested, if you please, add more details like your Show Debug Info, and maybe we can pinpoint what is going on, or in what instances it wouldn’t work.


Update: I did some further testing:

Some autocorrect works for me. Some spelling doesn’t seem to autocorrect, but some does. Double-space periods does work for me. Auto capitalization doesn’t seem to.

But then again, in Firefox, typing in this forum, none of it is working. In Chrome, the same set as Obsidian works. (Some autocorrect. Double-space periods.) So I tend to think this is an upstream “bug”, “feature” - whatever you’d call it - from Electron/Chromium.

I’ll move this back to Feature Requests for now. But it will be up to the developers whether they are willing or able to handle an upstream issue like this. Maybe they can override it.

1 Like

I’m using Android but in my experience, auto-correct also depends on the keyboard-app and -settings and probably universal access’ preferences too.

Thank you for moving this back to the Features Requests. I have the same problem as @Ninsuhn and there are other topics on the forum talking about this as well. I have the same behavior as @rigmarole like double-spaces, but no autocorrect at all. I tried to run with and without plugins and CSS snippets, as you suggested, @rigmarole.

Screen Recording 2023-11-14 at 16.00.13-2

This is my Debug Info (if others want to post that as @rigmarole suggest, please use on macOS the hotkey Cmd + P and type Debug):

SYSTEM INFO:
	Obsidian version: v1.4.16
	Installer version: v1.4.16
	Operating system: Darwin Kernel Version 23.1.0: Mon Oct  9 21:27:24 PDT 2023; root:xnu-10002.41.9~6/RELEASE_ARM64_T6000 23.1.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: adapt to system
	Community theme: Things v2.1.19
	Snippets enabled: 1
	Restricted mode: on

RECOMMENDATIONS:
	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

I really would love to see Obsidian support native macOS autocorrect!

4 Likes

To make that a bit more clear: those posts are indeed talking about that this problem is an inheritance of a bug/feature somewhere in the development tree of Electron/Chromium.

2 Likes

Yes, this continues to be an ongoing annoyance in the Mac app, though I know the problem is apparently an unpatched upstream regression or deficiency in Electron.

Hi there, just downloaded the Obsidian app and have recently gotten into it. This no autocorrect thing is quite annoying, is there a fix for it yet? If not, I’m surprised this doesn’t seem to be as big of a deal. Have others found a workaround for it? Thanks!

5 Likes

I am also surprised this isn’t a huge issue. Maybe I am a much poorer typist than most.

I have tried to recreate the ‘beleive’ > ‘believe’ example above, and I cannot. It autocorrects in all other places in Mac (including this textbox within safari) but it does not in Obsidian. Obsidian is close to unusable to me because of this, mostly because of my own poor typing!!

Am I missing a setting somewhere?

3 Likes

You do not miss anything. It seems to be an unpatched upstream regression in Electron according to @Synchronicity.

Can we extert influence on the development side of Obsidian, or is this all fully dependent on the development of Electron?

@archifont I’m not a dev, but I assume it’s an upstream Electron bug because the latest versions of Zettlr, Joplin, Logseq, and VS Code all have the same issue.

3 Likes

I had the same issue with Notion Mac desktop app. It uses Electron, and it misses this feature. When I use it with Safari, every thing is fine and all macOS typing features are working well. With macOS 14 Sonoma I added Notion as a Web app to the Dock, and using it is just fine as if it’s a desktop app. It uses Safari engine, and so all typing features are working well.

Is there a way to do the same with Obsidian?

2 Likes

Does anybody has an idea to efficiently file this upstream Electron bug at the Electron GitHub repo?

2 Likes

In Obsidian 1.5.8, the installer has been updated to Electron v28.2.3 which is good news—I think.

Probably a good thing, but native macOS autocorrect still doesn’t seem to be working even with the latest installer.

I think it is a good thing as well. Nevertheless, native macOS auto-correct is not working in Obsidian …

Would one think this will be solved version 1.6.0?

This is the biggest pain point for me writing on Obsidian. Over the years of using google docs I developed a habit of typing fast and making mistakes but adding every mistake I made to the autocorrect dictionary, this made typing very very fast. It’s a real shame I can’t do the same thing on Obsidian.

The conversation above suggests that this is to do with an electron bug, but it seems nobody knew the answers to the following questions:

  1. Is it possible for the developers of Obsidian to fix this themselves or are the dependent on electron?
  2. Someone asked if there was a way to ‘efficiently file this upstream Electron bug at the Electron GitHub repo’, but no one responded. Does anyone know how to do this? I followed the link but couldn’t work it out.

In short, I guess it would be good to know whether this really is a feature request, or whether we just have to hold tight and wait for electron to be sorted.

3 Likes