Setting to disable parenthesis shortcut for making special characters

Use case or problem

Obsidian use the open parens character as a shortcut for typing special characters. For example “(c” will be changed into a © symbol automatically. I rarely/never need to use special characters like © or ® when making notes. However, I frequently use parenthesis (like this) to enhance my notes. It is a daily occurrence that I end up with “©urrent)” instead of “(current)” when typing a note.

Proposed solution

Add an option in Obsidian Settings that would let users turn this behavior off.

Current workaround (optional)

  1. Try to remember to type a space after the parens like this “( current )”.
  2. Switch to using {} .
  3. Try to remember to press the esc key after typing the first letter after a parens.

All of these are unnatural and hard to remember.

Related feature requests (optional)

As an aside, these special character shortcuts dont appear to be documented anywhere that I could find. For people who do like this feature, it would be nice to have a list of the special characters that can be typed in this way. Through experimentation I found that you can type c, r, p and tm after a parens. I am sure that there are others, but I have no idea.

I don’t think Obsidian does this. Are you sure that isn’t happening in your OS, or in a snippet manager app?

What OS are you using?

1 Like

Embarrassingly, you are correct. After further research I discovered its a feature of MacOS that is buried deep in the settings. Its strange because I thought this may be the case before I posted this request and tested the “(c” thing in Apple Notes and TextEdit and Microsoft Word and it didn’t replace it in any of these apps, which is why I then assumed it was Obsidian.

If anyone else ends up here, turn it off in System Settings > Keyboard > Text Replacements

Sorry for wasting people’s time.

No problem! Glad you got it sorted. Macs can be a bit quirky in this department. Only parts of it seem to work, and it depends on the app: OS-level autocorrect in macOS