Opening vaults on iOS with obsidian doesn’t work

Things I have tried

On iPad with two vaults the obsidian uri approach resorts to current vault. I have looked at others stating such and resolutions without avail.

Using safari and links from Obsidian of:

obsidian://open?vault=My%20Work&file=inbox%2Fdefault
obsidian://open?vault=Home&file=Inbox%2Fdefault

These URLs are from the copy URL from a note in my vault and when entered into Safari they do not open the specific vault, just opens the current vault.

I have search Obsidian help blocks opening own vault
Creating or opening a new vault doesn’t work

What I’m trying to do

I am looking to open specific vault automatically with shortcuts, stuck on opening vaults automatically. I am using Obsidian version v1.0.3 on IPad.

Found the issue. When setting up on iPad use the iCloud location and not local storage on iPad for this to work correctly in dual vault situation.

It sounds like you solved your problem, but FYI: Obsidian URLs unfortunately don’t work right on mobile if Obsidian isn’t already started (for example, when you’ve switched away from Obsidian and used several apps, causing the system to push it out of memory). Here’s the bug report about it: