Open in default app on link only opens the markdown page

My right hand click context menu is configured to show the obsidian “open in default app”
command. But this command only opens the markdown page. If this by design, then please consider this a feature request instead of a bug report. There needs to be a way to open links in the default system app. When there are hundreds of files in the attachment directory, it can take minutes to find the linked-to file, and then open the default app from there.

Steps to reproduce

When I place the cursor on a link to a pdf stored in my attachment directory, and then run “open in default app” from the context menu, the pdf is not opened in the default app, but instead, what is opened is the markdown page the link was in.

Expected result

The pdf opens in my computer’s default editor

Actual result

The pdf page is not opened. The mardown page is.


Obsidian version: v1.4.16
Installer version: v1.4.13
Operating system: Windows 10 Home 10.0.22631
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Gitsidian v0.0.0
Snippets enabled: 4
Restricted mode: off
Plugins installed: 65
Plugins enabled: 50
1: Settings Search v1.3.10
2: Recent Files v1.3.8
3: Commander v0.5.1
4: Paste URL into selection v1.7.0
5: Janitor v1.0.7
6: Obsidian Git v2.22.0
7: Graph Analysis v0.15.4
8: Plugin Update Tracker v1.5.2
9: Tag Wrangler v0.6.1
10: Mermaid Tools v1.1.1
11: Outliner v4.8.0
12: Zoom v1.1.2
13: Mousewheel Image zoom v1.0.19
14: Text Extractor v0.4.8
15: Advanced Tables v0.19.1
16: Omnisearch v1.19.0
17: Auto Link Title v1.4.1
18: Wikilinks to MDLinks v0.0.12
19: Highlightr v1.2.2
20: Importer v1.5.6
21: AutoMOC v1.3.4
22: Timestamp Notes v1.0.8
23: Omnivore v1.8.1
24: Local Images Plus v0.15.9
25: HTML Reader v1.0.11
26: Excalidraw v2.0.8
27: Toggle Case v1.1.0
28: Calendar v1.5.10
29: Note Refactor v1.8.2
30: Better Command Palette v0.17.1
31: Hover Editor v0.11.15
32: Callout Manager v1.0.1
33: Lapel v0.1.1
34: Kanban v1.5.3
35: Consistent Attachments and Links v1.1.0
36: Image Converter v1.1.7
37: Advanced URI v1.38.1
38: Excel to Markdown Table v0.4.0
39: Dataview v0.5.64
40: Colored Text v0.6.0
41: Navigate Cursor History v1.1.0
42: Editor Width Slider v1.0.5
43: Editing Toolbar v2.4.0
44: Custom File Explorer sorting v2.1.2
45: Show Current File Path v0.5.2
46: Zotero Integration v3.0.12
47: Style Settings v1.0.7
48: Minimal Theme Settings v7.3.1
49: Daily Note Outline v1.3.1
50: Annotator v0.2.10

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

A few things here. Bug reports aren’t generally considered with any community plugins installed. You need to test in the Sandbox vault or your vault in Restricted mode with a restart, etc.

In your screenshot, the link you’re hovering over looks like an Obsidian URI link [2020....](obsidian://open?vault=VAULT&....) so that will open the note/PDF/whatever within Obsidian.

Exactly what ariehen said.

An Obsidial URL is an x-callback-url that is specifically designed to run a url callback into Obsidian. That is not a “link”.

If you make a link [[Electrical Reference.pdf]] then you already can right click and open in default app. Or an embed ![[Electrical Reference.pdf]] has a hamburger menu you can click to do the same.

And it works with right-clicking Markdown Links too:
[Electrical Reference](Electrical%20Reference.pdf)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.