Obsidian with Cryptomator - ENOENT: no such file or directory, unlink

Steps to reproduce

  • Use Windows 10
  • Install Cryptomator 1.7.5 (msi-4400)
  • Install Obsidian 1.1.16
  • Open existing Vault on a previously mounted Cryptomator Volume

Expected result

Obsidian should open the vault without errors

Actual result

Obsidian tries to open the vault but stops with an error: An error occured while loading Obsidian. Error: EISDIR: illegal operation on directory, watch "Z:\Obsidian\personal"

Looking into Dev Console shows following stacktrace:

Error: ENOENT: no such file or directory, unlink 'Z:\Obsidian\personal\.OBSIDIANTEST'
    at Object.unlinkSync (node:original-fs:1735:3)
    at e.testInsensitive (app.js:1:1095522)
    at new e (app.js:1:1095224)
    at app.js:1:2383533
    at app.js:1:235836
    at Object.next (app.js:1:235941)
    at a (app.js:1:234680)


	Obsidian version: v1.1.16
	Installer version: v1.1.16
	Operating system: Windows 10 Home 10.0.19045
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

I use cryptomator to encrypt my obsidian notes.

I read in this issue #13629 that Cryptomator uses Dokany Driver for virtual drives. And that Cryptomator deprecated use of Dokany with the 1.7.0 version.

Checking my cryptomator settings for virtual drives shows that only following types are avalable

  • WebDAV (Windows Explorer)
  • WebDAV (HTTP Address)

We don’t provide support for third party sync solutions. Reading the Cryptomator announcements, it looks like you need to looing into the FUSE-based solutions, like winfsp

Thank you for your response.

I checked cryptomator documentation and found that WinFsp drive (FUSE) is not installed on my system. After installation Download · WinFsp I could use the virtual drive in Obsidian without errors again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.