Obsidian Sync. There's something strange in it or it's a bug

When you rename the Untitled2 file to UNTITLED2,
sync completely and restart obsidian.
This file is replaced by Untitled2 again, i.e., UNTITLED2 is deleted.


Steps to reproduce

Here’s the 50 sec video:

Expected result

Nothing should happen. The file UNTITLED2 should remain unchanged.

Actual result

Delete the UNTITLED2 file and replaces it with the old Untitled2.


  • Operating system: Win 10
  • Obsidian version: v0.12.3

Does this happen only with files that differ by capitalization?

Is the file actually renamed in your OS?

Where are these files synced to?

Do you have any other sync/backup service running on these vault?

Windows has a case insensitive filesystem … last time I checked.

Windows has a case insensitive, case preserving file system. It might play a role in this.

Yes. And this happens on my work computer. I don’t have this problem at home, though I will check this point a few more times today. Also, I can’t rename so that all the letters were small. Example: I need from “Sport”, to be “sport”. As a result, after synchronization I gеt “Sport” again.

No. I checked. The file name does not change at all.

I use Obsidian Sync with encryption and on the local machine I have the vault itself in an encrypted container - I use VeraCrypt. But I don’t see this problem on my home computer, where I use the same things. I will check this point a few more times today.

No. Absolutely not. I specifically bought Obsidian Sync to use the native sync. The VeraCrypt container itself is on drive C. Everything I sync is all on drive D, so there’s no way that can happen.

As a backup tool that runs just in case for Win 10 in manual mode - only Acronis True Image. It makes a backup to the local machine. But I don’t see this problem on my home computer, where I use the same things.

Just created a new vault and tried to rename titles (files) without synchronization and encryption - everything works as it should.

What do I need to do to find the cause of the problem?

If the file isn’t actually renamed in your OS, this explains what is happening.

I believe the cause of this problem is in the filesystem on the encrypted partition or in veracrypt itself. Which filesystem did you use to format your encrypted drive? Did you use FAT?

I just checked on my home computer (drive D - NTFS) - this problem does NOT exist.

On the work computer - most likely NTFS as well. Tomorrow I will say for sure.

Not the conteiner driver (D:), the conteined A:

Yes, at work I have FAT32.

I recreated the container in NTFS - everything worked properly! No problem - everything works as it should.

The server is slowing down today.

@WhiteNoise Thank you so much for your help!!!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.