Obsidian Sync seems to delete files?

Steps to reproduce

I started using Obsidian Sync a couple of days ago and today I noticed that dozens of notes got deleted. The problem: It wasn’t me. The files are NOT in iCloud but in my user folder. If I open the deleted files section in the sync settings I can see my files but not restore them (see screenshot below). It simply says: This version is already the latest version.


  • Operating system: MacOS Big Sur 11.1
  • Obsidian version: 0.10.7

Additional information

1 Like

where do you sync these files? Did you set your whole home directory to be your vault?

I have an Obsidian folder in my home directory which contains my vault.

what is the situation in the other computer?

That’s weird… let’s address the two issues separately:

  • Notes getting deleted: Any chance you’re using third party plugins that could be causing deletions? Anything else you’re running on your computer that’s using the folder (you mentioned it’s not on iCloud, but just wondering if there’s anything else).
    Any chance your other machines may be doing something to wipe the files?

  • Restore: I believe you’ll need to navigate to an earlier version of the file to restore it. If it says “This file was deleted”, then that’s just the timestamp/version that the file was deleted at.

I have not dared to look at this point. :grinning: Tried to get the missing files back first.

Definitely start with damage control first. Make sure you have backups and we’ll continue to debug the issue once your files are safe.

I do have several layers of backups thankfully. I’ve never been more grateful for Time Machine than today!

1 Like

I think I figured what has happened… I sync an iMac and a MacBook and on the MacBook I had my vault still in iCloud. iCloud and Obsidian Sync messed with each other resulting in data loss. No further incidents so far.

However, I wonder if my issues occurred because one end lived in iCloud whilst the other didn’t? What is the best practice here? Can iCloud and Sync coexist?

1 Like

I haven’t checked if this has come up elsewhere, but I’m concerned about this same issue. At the moment I backup my Obsidian vault in iCloud and it’s worked fine if I switch over from my laptop to mobile to at least access my markdown files. But I’m not sure how it’ll work with Obsidian Sync.

1 Like

I think they can coexist.
However, if you removed the directory from icloud in one computer, it’s possible that at tha moment Icloud deleted your files.

I think that I’m having the same issue with Sync on Obsidian v0.10.13 (AppImage). I’m running a Debian-based OS and my Obsidian release is fresh (MD5: 3c7f470ac97abc83c172d6844920ab03). I do not have any other plugins installed. Every time I close Obsidian, 1-3 files are being deleted at random. None of the files effected have been modified recently. For the sake of troubleshooting, I pushed my notebook to a new remote vault: The issue is persistent, and many of the files being lost have no version history and have never been deleted prior. Before exiting the application, the status icon has always shown that the files are fully synced. There are no exceptions raised in the error log. There are no other programs installed that should be interfering with my files locally. The missing files are not being moved into my system’s recycle bin or the vault’s .trash directory. The version history has saved me thus far, but every time I open Obsidian I have to go into Settings > Sync > Deleted Files and recover a few files tagged as [deleted] a few seconds ago. This behavior only occurs when Sync is enabled. I haven’t experienced any problems while the plugin is paused or when working with untracked vaults.

Thanks for your report. Did you notice any pattern in the files that are deleted?
Do you use obsidian sync only on one computer?

@Jevin if you care reproduce this problem reliably, you could really help us nail it and solve it.

Thank you for the detailed description. If I understand correctly, that means somehow Sync is deleting the files on application boot-up (rather than shutdown?) based on the timestamps. If you read the vault folder, right after closing the app, do you see the files disappear, or does it only disappear once the app boots up?

When you boot the app up, and view the sync log, do you see it say “Deleting remote file …” for the files that have been removed?

(Also just following up what WhiteNoise said, any patterns in the file names perhaps, special characters, or maybe just a long directory/file path?)

Sorry for the delay guys. I’ve been very busy and it slipped my mind. I was only taking Obsidian for a test drive, so I did not retain those vaults for any further testing. I do still have screenshots of an example (albeit not a particularly useful one) from the other day though. I’m preoccupied with PWK/OSCP right now, but once I finish I would be happy to help troubleshoot.

And yes the deletions were on application startup. There weren’t any special characters or anything in the absolute or relative filepaths. I think I opened my first vault in Windows once, but that wouldn’t explain the second vault.


Oh yeah just to rule out possibilities, were you using any community plugins?

And also, you said the files were deleted at random, but was there any pattern as to which files they might have been? Possibly related to having them open/navigated to, etc?

I doubt this is of much use but wanted to document. I’m running multiple vaults in Sync with a MacOS Big Sur installation and a current Windows machine. Stumbled onto 2 files this weekend that had disappeared from my vault. I did not delete them (not knowingly!) as they were both large Index/MOC type notes. Both represented a lot of work and I was pretty stunned to hover over an internal link and see “file not yet created”.

This was not the disaster it could have been - the windows machine has not had Obsidian opened since last Wednesday. I was able to remote into that machine and copy the .md files for each from the folder they reside in over there. Tomorrow I will back up both vault folders before opening Obsidian on that desktop just in case more files are missing that I haven’t discovered yet.

I realize this is not much help as a bug report as I don’t know when it happened or have any ability to reproduce. Just wanted to document for reference. This occurred sometime after Wednesday noon Jan. 27 and prior to Saturday noon Jan. 30. I’m always using the latest insider release so I was on 0.10.10 for the early part of that time period then updated to 0.10.11. I use several community plugins.

Is this vault being synced by other backup services, like iclould, dropbox, google drive?

No other backup services.

I don’t know how the history feature works? I have already recovered the files and copied the new versions into the vault.