Obsidian Sync not syncing plugins etc?

I am a paid user of Obsidian sync and I set up obsidian on 3 devices (2 desktop, 1 mobile) this way:

  1. Create a new obsidian vault named notes
  2. Enable sync plugin and sign in
  3. Connect to remote obsidian sync.

I’ve gone into obsidian sync settings and made sure literally everything is set to sync

Nevertheless, settings don’t seem to be copied over to other vaults when I make them on one of the desktop devices.

For example, yesterday I installed Minimal theme and set up minimal theme settings plugin on my home pc. I’ve now arrived at work and none of those settings have been carried over.

Am I supposed to be setting up these vaults and sync in a different way?
Is there a better way to ensure syncing actually works?

I’ve just gone through and checked all the sync settings again on my work pc (I could have sworn I checked them already?)… but I had to go and manually download the minimal theme options plugin as it wasn’t enabled in the sync?

I can see in the sync log window that the latest version on my home pc has the plugin in the list, why wasn’t this applied when I enabled syncing?

3 Likes

Yes obsidian sync can sync themes and plugins.
I don’t know how you configure it.

Do you (@WhiteNoise) have Sync working where your themes and plugins are syncing across devices?

Like the OP, I followed all of the instructions (to the best of my knowledge anyway) and none of my plugins or theme changes are synchronizing across my 3 devices (PC, iPhone & iPad).

I even tried turning those options off and back on again to no avail.

@Rai - I assume you haven’t found a solution yet?

yes, I do.

That is good to hear! Can you share how you accomplished it?

What is your setup? (device types and OSes and number)

Did you ever experience this problem, or did yours work straight away?

Finally, what process did you use to setup both your vaults and sync on the different devices?

For me, I originally tried to use iCloud Drive as the sync method. My main computer is a Windows 10 PC and I had the “Microsoft Store” version of the iCloud app installed. Like many others (seemingly also with Windows using iCloud) there were odd file copies being created that literally “breaks” the Osidian vault (you can’t open any file at times and indexing stalls). There was a recommendation to download the old iCloud version from Apple, which I did, but the same problem happened. While it was working, everything synced just fine including all plugins and themes, etc.

Because of the random duplicate corrupted files issue, I decided to plunk down my money for a year subscription and use Obsidian Sync.

My setup process:

  1. From my Windows PC, I moved my vault to my local drive without any type of other cloud storage replication.
  2. I then created a remote vault through Obsidian Sync with the same vault name and started to sync everything (with every option enabled)
  3. I waited for this process to finish where it said “Fully Synced” (I have around 2,600 notes)
  4. I then created an empty vault on my iPhone on local-internal storage (not using iCloud) of the same name.
  5. I enabled Obsidian Sync on my iPhone, pointing to the same (and only) remote vault.
  6. I enabled all sync options for plugins, settings, themes, etc., and then let it sync (I saw that it synced the plugins and themes)
  7. I followed the same exact process on my iPad that I used for the iPhone, again enabling all options

My plugins and themes and settings are not carrying over to my iPhone or iPad (even though it looks as though they synced).

As I said earlier, I tried disabling and re-enabling the options to sync settings and plugins… but nothing changed.

One interesting fact, when I went into “Appearance” and themes, all the themes were present and I was able to select the one I wanted, but it didn’t happen automatically.

While themes do show up as “available”, the Community Plugins shows “0 installed plugins”, even though I saw them sync.

I’m at a bit of a loss, but this is important for me for this paid service.

I am certain I could have missed reading something or did something wrong… but to the best of my ability I haven’t figured out a fix to this issue.

change a settings on desktop
Post a screenshot of the sync log on desktop and on mobile.

Desktop - Installed the Breadcrumbs plugin

iPhone - Breadcrums plugin synced

and the plugins page after the sync

1 Like

Ok looks like it’s working? What’s the problem?

1 Like

It sounds like you’ve tackled this thoroughly. But I’m asking anyway: Are you sure you cleaned up all the duplicate files? Including any hidden files and ones tucked away in subfolders?

1 Like

You mean the syncing of things in the background is working? Yes. Files are syncing.

You mean the differences are being applied? No. You can see in the last screenshot, taken after the sync of the plugins, it shows “You currently have 0 plugins installed.”

Am I not understand the capabilities of Obsidian Sync correctly? I am under the impression that syncing settings, themes and plugins should actually apply those changes on the other devices. Is that not how it is supposed to work??

1 Like

Thanks for the reply @rigmarole!

You bring up a great point! I will have to dig into all of the sub-folders and hidden stuff to see if I maybe missed something. I believe I had cleaned everything up since the last issue, but maybe I didn’t or something got jacked up after my last cleanup pass and moving it out of iCloud.

I’ll update after I scrub everything.

I think maybe you nailed it (??)

Here is my .Obsidian folder inside my vault. There are two files that have the (1) and (2) in their name, and that’s exactly what was causing problems before… but I am also noticing a lot of other files (all selected) that I am wondering if I should delete them (or is it normal and needed possibly?).

The other files with numbers (the ones not in parenthesis) seem like they are copies/versions that do not have the most up-to-date settings.

Thoughts/recommendations?

I would say that is the source of your problem. I don’t think any of the files should have numbers.

Backup first, but I’d say delete them all if they have a number at the end.

1 Like

I closed Obsidian and moved those files out of my vault (keeping them just in case). I then started Obsidian and looked at the sync log and saw it removed those files from the remote vault. I then opened Obsidian on my phone, it did a sync and BOOM, my plugins are all there and even enabled!

Now, one last thing: I made sure that appearance settings sync is enabled and made a change on my desktop by choosing a different theme. The change didn’t carry over to my iPhone, even though the theme is present on the iPhone. I then made a couple changes to which theme I was using on the iPhone, looked at the sync log and see that the appearance.json file was pushed from my phone to the Sync vault. I can also see that the changes went in both directions when I was making theme changes on my desktop sync log… but the theme isn’t automagically changes across devices.

Looking in File Explorer, there is only one appearance.json file and the timestamp looks good.

I swear I saw a video of someone changing their theme and it happening quickly and automatically on their phone. Am I wrong??

Honestly, manually picking a theme on each device is not a big deal to me… just making sure I am not missing something or that something is still wrong.

To be at the point that I am now with the plugins all working has me jumping for joy! Thanks for the suggestions @rigmarole!

1 Like

I am just providing an update here around the theme syncing. I honestly did nothing other than shutting down my Windows PC at one point (that I can remember anyway), instead of my normal case where I just put it to sleep and leave Obsidian “running” at all times.

At any rate, the theme changes now seem to be syncing across my desktop and iPhone. That is awesome, and now I will likely turn that off so I can use a different theme on my iPhone. :joy:

I honestly don’t know why it started working all of a sudden, but I’m happy.

One final question: On my iPhone, when I launch Obsidian and it runs though the sync, it displays a message very quickly that says something like “Plugin failed to load”, but it disappears quickly and I may be missing some of the wording. I know how to launch the “console” on the desktop version (Ctrl+Shift+i), but not sure how to do this on the phone (iOS if that matters).

Where could I find that message and track down the issue?

For the failed plugin, I’m not sure. Alternatively, if you’re willing, you can list your plugins and maybe someone knows a certain plugin that is not supported on iOS. I know some of them are not.

There is a command “Show debug info” which lists your plugins.

I was able to see the message this time as I launched Obsidian on my phone. It is the “Checklist” plugin, which I believe doesn’t work on mobile.

I didn’t try the debug mode to see what that might show, but will remember that for future issues.

Thanks again for all the help!! Loving life. :grin:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.