Obsidian Sync: Cannot open email support link

Steps to reproduce

Go to Sync settings and click this “Email support” button.

Did you follow the troubleshooting guide? [Y/N]

I’m aware that I didn’t fully follow it, but I believe this bug report is different in character from the general one, so please excuse this exceptional treatment.

(I sent an email to the support about this issue, and they asked me to report it on this forum)

Expected result

A mailto: link is automatically opened, or a confirmation popup appears with a clickable button in it.

Actual result

There appears a very long popup containing a mailto: link with a URL-encoded debug info.

The popup is so long that the “Open the link” button completely goes outside my screen, so I can’t press it.

(I hided the debug info part because it contains some personal infomation)

Environment

Here’s the debug info for my main vault, but the same problem also happened when I created a new empty vault and set up Sync in it with the same remote vault.

SYSTEM INFO:
	Obsidian version: v1.4.14
	Installer version: v1.4.13
	Operating system: Darwin Kernel Version 22.6.0: Wed Jul  5 22:22:52 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T8103 22.6.0
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Minimal v7.3.2
	Snippets enabled: 29
	Restricted mode: off
	Plugins installed: 97
	Plugins enabled: 51
		1: ZotLit v1.1.2
		2: Word Splitting for Japanese in Edit Mode v1.0.0
		3: Toggl Track v0.11.0
		4: Templater v1.16.3
		5: Tasks v4.9.0
		6: TagFolder v0.18.3
		7: Tag Wrangler v0.6.1
		8: Style Settings v1.0.7
		9: Better Search Views v0.2.2
		10: ABC Music Notation v1.4.0
		11: Advanced URI v1.38.1
		12: Another Quick Switcher v9.1.1
		13: Auto Card Link v1.2.2
		14: Auto Link Title v1.4.1
		15: Better footnote v1.0.1
		16: Calendar v1.5.10
		17: Commander v0.5.0
		18: Convert url to preview (iframe) v0.5.0
		19: Embed Code File v1.2.0
		20: Excalidraw v1.9.23
		21: Extended MathJax v0.4.1
		22: Floating Search v3.4.5
		23: Footnote Shortcut v0.1.3
		24: Hider v1.3.1
		25: Image Captions v1.1.0
		26: Image Toolkit v1.4.0
		27: Lapel v0.1.1
		28: Latex Suite v1.8.4
		29: Linter v1.20.0
		30: Minimal Theme Settings v7.3.0
		31: Natural Language Dates v0.6.1
		32: No more flickering inline math v0.1.3
		33: Obsidian Charts v3.7.2
		34: Obsidian Git v2.22.0
		35: Obsidian42 - BRAT v0.7.0
		36: Obsidian42 - Strange New Worlds (SNW) v1.2.2
		37: Paste URL into selection v1.7.0
		38: Periodic Notes v0.0.17
		39: Query Control v0.6.0
		40: Settings Search v1.3.10
		41: Scroll Offset v1.0.4
		42: Search on Internet v0.5.0
		43: Quick Switcher++ v3.3.7
		44: Quick Latex for Obsidian v2.6.3
		45: Filename Heading Sync v1.9.0
		46: Custom Frames v2.4.6
		47: Spaced Repetition v1.10.2
		48: Heatmap Calendar v0.6.0
		49: Hover Editor v0.11.14
		50: Dataview v0.5.61
		51: QuickAdd v1.4.0

RECOMMENDATIONS:
	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I do know how I can solve this issue.

  1. Insert an email link (that is short enough) in a note
[Email](mailto:[email protected])
  1. Click it, and turn on “Always open mailto: links in the future”, and then click “Open this link”

But I just wanted to let you know about this problem.

I don’t think it’s really a “bug” but I suspect it is something unexpected.

well that interface is outside our control. It’s for your safety to see the whole URL.

Yeah I do understand the intention. It would be better if the URL is put in a scrollable field so that the popup fits into the screen.

the problem is that we don’t make that window. I am not 100% sure but it’s either electron or your OS. I’ll double check.

I see… Thanks, I hope it is something fixable.

Double post, because I mentioned this in this thread too, but:

This seems like it might be fixed? Tested on MacOS Obsidian 1.4.16 and the data is inside a scrollfield for me.

I will double check this again.

1 Like

Sorry, I was missing your reply in the linked post. I can’t retry because I have already opened another mailto: link, so electron (maybe) doesn’t show me the message anymore.