Obsidian should request Calendar permission to access user calendar

Use case or problem

I’m using Obsidian (great product, thanks!) on macOS. I’m using Templater plug-in to create notes with icalBuddy shell command. It used to work well (with a few tweaks mentioned in thread here), and after I upgraded to Obsidian v1.0 and macOS Ventura (13.0), it stopped working to load the personal calendar in macOS.

Shell command in Templater:
/usr/local/bin/icalBuddy -npn -nc -ps “/: /” -iep “datetime,title” -po “datetime, title” -b "\n\n### " -tf “%H%M” -ic “Calendar” eventsToday

It works in shell window (Terminal) and other tools (SwiftBar), which would trigger the prompt for calendar access, but it didn’t prompt in Obsidian. Obsidian didn’t request permission for Calendar and is not added to the Calendar permission list under Privacy & Security setting.

Have not tried uninstall and reinstall Obsidian as I don’t want to lose current settings.

Environment

  • Operating system: macOS Ventura

Proposed solution

Obsidian should request Calendar permission to access user calendar.
SwiftBar solved the similar problem in this PR.

Current workaround (optional)

None, I will have to manual run it in Terminal and copy the markdown to the note.

Related feature requests (optional)

1 Like

Reinstalling desktop Obsidian won’t lose your settings — they’re entirely contained within your vault(s) (in the .obsidian folder).

(Reinstalling mobile Obsidian, at least on iOS, will lose your settings and all of your notes, so backup.)

1 Like

Thanks for the advice, but reinstalling v1.0.3 doesn’t solve the problem (although settings are retained).