Obsidian on mac 14.0 has blank screen, tried restarting

my screen is blank. I go to file to open new vault (it sees my vault) but still blank screen. Literally… blank. The white box is the result of “Open Vault.”

Try moving the .obsidian directory out of your vault and then opening it.

If it works, there is a plugin, theme, or snippet issue (more than likely plugin).

If it still doesn’t work, could be something else going on.

I can’t access anything anywhere in the obsidian desktop app. There is no opening or adjusting anything. Any suggestions for accessing plugins when there is nothing to access? Some secret back door?

Sorry, your Obsidian Vault is just a folder with files in it on your hard drive.

Where you have your Obsidian Vault stored there will be a hidden folder (.obsidian).

Find that and move it out.

Thank you. How do I “move out” the folder .obsidian? I understand it is on my hardrive on my computer.

I have a folder on my hardrive on my computer which is connected to my Obsidian desktop app, ie, the hard drive folder updates new .md files everytime I create one in Obsidian. In this folder on my computer does not exist anything called .obsidian. Everything in it is a .md file. There are only files I created in Obsidian in this folder.

Are you on a mac?

If so press CMD + SHIFT + . (command shift period) and that will show hidden folders.

It is 100% there.

All you want to do is copy it, paste it on your desktop, then delete the one in your obsidian folder.

I definitely pushed cmd + shift + . (command shift period) and absolutely nothing happened. Just the blank screen of obsidian. I restarted the application and repeated the process. Absolutely nothing. There is no vault, no nothing. No response.

How to Access Your Mac's Hidden Files | PCMag.

I do have a folder on my mac that I can access from my desktop that contains all my .md files of Obsidian, but I cannot access it or any other folder from Obsidian.

You should access it from finder, and use cmd-shift-. in finder.

Ok. So I found it in finder, made a copy of it, put it on the desktop, then clicked the commands you suggested, the folder which was blue on my desktop turned a grey color after pushing the commands.
I threw the one in the finder in the trash. I went back to the desktop, and the folder was still grey. I couldn’t open it or do anything with it, so I clicked the same commands again, thinking that maybe it would un-grey it, but it actually disappeared. Like no where anywhere on my computer. So I went back to the trash to try and recover it. It was there, also grey, soI clicked the commands again, and it disappeared, from the trash. Soooo it is now no where. Oh dear me…

  1. Open Finder
  2. Go inside the directory corresponding to your vault
  3. Press cmd-shift-i
  4. A folder called .obsidian should appear.
  5. Move (not copy) this folder somewhere else
  6. Start Obsidian

Ok I did that. Obsidian still blank, even after restarting. It looks like the image at the top of this thread. Thank you for trying to help me. I don’t know what else to do.

I uninstalled Obsidian and reinstalled. That seemed to work. Thank you very kindly for all your help and attention. I very much appreciate it.