Obsidian on Linux is Slow to point of Unusable

@Erisred I use AppImage in Linux and never experienced slowness with one Obsidian instance open.

is your Linux file I.O still fast?

@ThatOrchid there is a lot of information that is useful to us in the template! Could you please let us know the following:

  • which Obsidian version you have?
  • which installer version?
  • What installation method did you use (AppImage, Snap, Flatpak, or other of the supported ones)?
  • What OS are you on?

This happened to me on Windows when I activated a cursor feature to make it fancy.

I’m on linux manjaro XFCE and have never had any slow performance either.

I use obsidian through an AUR install which is technically the same as the .AppImage, I’ve also tried Flatpack and Snap and none seems to have slow performance issues.

This is not a broad issue. It’s something that this user is expiriencing and we are trying to figure out why.

I believe you mean to direct this to @ThatOrchid - I’ve had no issues on my end - with the OS in general, nor with Obsidian.
Thanks for asking, though!

I have a similar problem.

I am running Debian 10 “Buster”, and I have tried both with Flatpak, Appimage and through .deb installers, same result. I can install and run the package just fine, but when I open it, I get an almost entirely unresponsive window.

However, this only happens when I open it in an X11-based window manager, as is my daily work environment (AwesomeWM). I tried logging in to Gnome on Wayland, and Obsidian ran smooth as a hot knife in butter.
To check whether it was an Awesome problem rather than an X problem, I logged in to Gnome on X, and tried to run Obsidian - which was unusable. So I am pretty sure that at least for me, it’s an X vs. Wayland issue.

I am wondering if there is some GPU rendering issue or something that does this?

I had the same problem. I use Appimage Obsidian 0.10.6 in mxlinux 19.2 using debian 10 buster as a base.

While I used the Googlechrome browser, I started the obsidian (appImage) and changed the themes, then it suddenly slowed down to a halt and no response. I see this could be a problem of the electron base or whatever. Then I closed it from the panel icon, and then restarted it, it seems ok.
Could this be due to themes? what if I had choosed the troublesome theme, then how do I reset it back to the default? Is this theme changing or other than default theme caused problem while changing? I don’t know.

I plan to install it thru snap package instead of appImage, then it asked me to install in user mode or system mode? I am planning to install as a system snap application, so it may have access all over them system.

Now it seems ok. I am not going to change the theme 80_neon which is selected by me. If the problem comes, I will raise it.

Thank you everybody for the datapoints.
I also think that this is not an obsidian internal problem but something external at electron/os level.

I am not convinced that this a broad X11 issue because X11 is quite popular and we would have many more reports.
Perhaps it’s problem with specific GPU drivers and this should happen in other electron apps.

You can try to start obsidian w/o gpu accelleration with --disable-gpu

Which Window Manager or DE are you using? And which display manager? As I wrote above, the problem shows when I use X Windows based environments, but everything is fine in Gnome on Wayland. Have you tried experimenting with this?

You are right, disabling GPU acceleration worked. Is there a way to do this permanently so I don’t have to call Obsidian from the command line every time? I tried looking through the settings menu but haven’t found anything so far.

You can add it to your obsidian.desktop file

Thanks. May I suggest that this be a switch in the Settings menu? It’ll be a quick and simple way for users to switch off some problems they might have.

I do think that there was a (related) feature request for that: Option to disable hardware acceleration but was merged into another bug report. I’ve reopened it in case you want to add a comment there, but feel free to open a separate #feature-requests if you like.

1 Like

–disable-gpu fixed the issue. Thanks everyone!!

1 Like

I have left a comment in the feature request.

Over the last few days I have had an issue with Obsidian being slow. My file probably totals about 1Mb and a opening time of about 15 seconds.

I downloaded the appappimage and instantly it dropped to about 1 to 2 seconds.

On another note, I was unble to open any of my virtual box VMs. It appears that I’ve done a kernel upgrade and had to go back to .4 version. Seems a bit much of a coincidence for me :slight_smile: In the meantime I will look at keeping the appimage and see what happens when 5.8 is more stable.

Interesting. Glad you’re getting to the bottom of it.
FWIW, my Manjaro system is currently using 5.10.2 kernel. I see ~10sec startup, but that setup is an older i3 with 8g of ram. Still - once I’m in, I see no real difference as compared to my i7 surface with a SSD.
I’ve been using the AppImage for months now, with zero issues.

1 Like

I’ll move this to the archive since it seems to work now for the OP. If someone in the thread is still having issues, please open a new #bug-reports using the template so we have all the required info.

1 Like