Obsidian on Linux is Slow to point of Unusable

I had the same problem. I use Appimage Obsidian 0.10.6 in mxlinux 19.2 using debian 10 buster as a base.

While I used the Googlechrome browser, I started the obsidian (appImage) and changed the themes, then it suddenly slowed down to a halt and no response. I see this could be a problem of the electron base or whatever. Then I closed it from the panel icon, and then restarted it, it seems ok.
Could this be due to themes? what if I had choosed the troublesome theme, then how do I reset it back to the default? Is this theme changing or other than default theme caused problem while changing? I don’t know.

I plan to install it thru snap package instead of appImage, then it asked me to install in user mode or system mode? I am planning to install as a system snap application, so it may have access all over them system.

Now it seems ok. I am not going to change the theme 80_neon which is selected by me. If the problem comes, I will raise it.

Thank you everybody for the datapoints.
I also think that this is not an obsidian internal problem but something external at electron/os level.

I am not convinced that this a broad X11 issue because X11 is quite popular and we would have many more reports.
Perhaps it’s problem with specific GPU drivers and this should happen in other electron apps.

You can try to start obsidian w/o gpu accelleration with --disable-gpu

Which Window Manager or DE are you using? And which display manager? As I wrote above, the problem shows when I use X Windows based environments, but everything is fine in Gnome on Wayland. Have you tried experimenting with this?

You are right, disabling GPU acceleration worked. Is there a way to do this permanently so I don’t have to call Obsidian from the command line every time? I tried looking through the settings menu but haven’t found anything so far.

You can add it to your obsidian.desktop file

Thanks. May I suggest that this be a switch in the Settings menu? It’ll be a quick and simple way for users to switch off some problems they might have.

I do think that there was a (related) feature request for that: Option to disable hardware acceleration but was merged into another bug report. I’ve reopened it in case you want to add a comment there, but feel free to open a separate #feature-requests if you like.

1 Like

–disable-gpu fixed the issue. Thanks everyone!!

I have left a comment in the feature request.

Over the last few days I have had an issue with Obsidian being slow. My file probably totals about 1Mb and a opening time of about 15 seconds.

I downloaded the appappimage and instantly it dropped to about 1 to 2 seconds.

On another note, I was unble to open any of my virtual box VMs. It appears that I’ve done a kernel upgrade and had to go back to .4 version. Seems a bit much of a coincidence for me :slight_smile: In the meantime I will look at keeping the appimage and see what happens when 5.8 is more stable.

Interesting. Glad you’re getting to the bottom of it.
FWIW, my Manjaro system is currently using 5.10.2 kernel. I see ~10sec startup, but that setup is an older i3 with 8g of ram. Still - once I’m in, I see no real difference as compared to my i7 surface with a SSD.
I’ve been using the AppImage for months now, with zero issues.

I’ll move this to the archive since it seems to work now for the OP. If someone in the thread is still having issues, please open a new #bug-reports using the template so we have all the required info.

1 Like