Obsidian on Linux is Slow to point of Unusable

Hey, I was using Obsidian for about a month and then all of a sudden, it starting becoming incredibly slow. It takes up to a minute to register an action including, typing, creating a new page, and basically anything at all. It often just freezes as well. Has anyone else experienced this?

Does it happen only when the help vault is open?

How many files do you have, how big is your vault?

can you record and share a performance profile?
Ctrl-shif-i->performance->record while it is slow ->export to file -> zip it and send it to us.

Also, first and foremost? does this happen with default css and no third party plugins?

I use obsidianite theme and no third-party plugins. I have 1 vault which the app opens into by default. It is 103 items, totalling 2.4 MB. I just turned off obsidianite and am using the default theme and still have the same issues. Even navigating the dev panel is slow. I recorded the performance profile. How/ where would you like me to send it?

you can zip it and upload it here, on dropbox/gdrive and send me the link or you can dm it to me on discord.

Did you use appimage, snap or what?
can you also send a zipped ~/.config/Obsidian/cache ?

What’s your discord username/number?


Can report no issues using both Linux Mint and Manjaro KDE. No slowness at all in a vault with ~800 files.
Must be something in the setup slowing you down. Hope you’re able to find it!

Are you using AppImage, Snap, or Flatpak?

I’m sure you’re asking OP, but for me, I avoid snap at all costs (don’t even have it installed on my main rig - a lot of *nix systems don’t even include it anymore). Even a cursory search will show it’s buggy at best.
Appimage all the way - it’s been nothing but stable for me. For most programs I’ve used, including Obsidian. And it’s dead simple to install.

Ubuntu 20.10 flavors replaced the package manager with basically snap manager.

@Erisred I use AppImage in Linux and never experienced slowness with one Obsidian instance open.

is your Linux file I.O still fast?

@ThatOrchid there is a lot of information that is useful to us in the template! Could you please let us know the following:

  • which Obsidian version you have?
  • which installer version?
  • What installation method did you use (AppImage, Snap, Flatpak, or other of the supported ones)?
  • What OS are you on?

This happened to me on Windows when I activated a cursor feature to make it fancy.

I’m on linux manjaro XFCE and have never had any slow performance either.

I use obsidian through an AUR install which is technically the same as the .AppImage, I’ve also tried Flatpack and Snap and none seems to have slow performance issues.

This is not a broad issue. It’s something that this user is expiriencing and we are trying to figure out why.

I believe you mean to direct this to @ThatOrchid - I’ve had no issues on my end - with the OS in general, nor with Obsidian.
Thanks for asking, though!

I have a similar problem.

I am running Debian 10 “Buster”, and I have tried both with Flatpak, Appimage and through .deb installers, same result. I can install and run the package just fine, but when I open it, I get an almost entirely unresponsive window.

However, this only happens when I open it in an X11-based window manager, as is my daily work environment (AwesomeWM). I tried logging in to Gnome on Wayland, and Obsidian ran smooth as a hot knife in butter.
To check whether it was an Awesome problem rather than an X problem, I logged in to Gnome on X, and tried to run Obsidian - which was unusable. So I am pretty sure that at least for me, it’s an X vs. Wayland issue.

I am wondering if there is some GPU rendering issue or something that does this?