Obsidian note freezes on switching to different note

Steps to reproduce

I have tried the following two issues but still having the same issue.

Obsidian freezing after being left idle
Obsidian consistently freezes on note switch/create after ~15+ minutes idle

Expected result

To be able to immediately switch to another note.

Actual result

Note switch view accepts no input, yet the cursor freezes and takes a long time to load the contents. Even after the contents have been loaded, scrolling is unresponsive. I’ve restarted my computer after removing all of the plugins and reinstalling the obsidian note. I’ve also removed the “System Monitor” tool from the Ubuntu machine, but the problem persisted.


Distributor ID: Ubuntu
Description: Ubuntu 22.04.1 LTS
Release: 22.04
Codename: jammy

  • Operating system:
  • Debug info:

Obsidian version: v1.0.3
Installer version: v1.0.3
Operating system: #59-Ubuntu SMP Mon Oct 17 18:53:30 UTC 2022 5.15.0-53-generic
Login Status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Wrap with shortcuts v1.2.0

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Post a screen recording of this happening in the sandbox vault.


I’m unsure where is this sandbox vault is located. I’ve never used it before.

lower left corner ? → Open sandbox vault.

I’m getting the note stuck on like the screenshot attached

That’s not the sandbox vault. I can’t reproduce your problem. Let’s see if someone else reports this problem.

Where is your vault stored? Are the files truly local? Is handled by other third party sync services?

Do you get errors in console (ctrl-shift-i)?


I did open in the obsidian sandbox vault and imported my files into the sandbox vault created by obsidian and still freezes when I switch to that very specific note but works fine with other notes I have. All my vaults are in my machine, there’s no third-party sync involved. I do not get any errors in the console at all.

Attach a copy of the note that is causing this.


I have attached a similar file which causes the same issue. I cannot attach the original file due to sensitive data, however, I have attached a file which reacts the same way as my original note data. It looks like it’s causing it because of a large amount of data in a single note which is around 960000+ characters.

Note: A huge list of wordlists containing over 960000+ characters works fine but if the data contains like the Freezer.md (attached file) then obsidian freezes.
Freezer.md (948.1 KB)

It doesn’t crash for me, but we don’t support these kind of data-dump files.

Oh, this is odd. I have tried all the versions for Linux and it still freezes. THere’ no way around this issue?.

At the moment our parsers doesn’t digest these files full of junk. It’s not the file only it’s the effect of these file on the vault, on linked and unlinked mentions in ingoing and outgoing links.

Maybe we’ll improve in the future.