Obsidian not showing images

I am having some difficulties with some markdown notes with images. Some notes display fine in Obsidian but some other don’t.

Things I have tried

I have tried:

  • Moving the notes and images to another folder Ext4 instead of NTFS
  • Reading the Obsidian help
  • I have checked the link to the image in both notes, displaying an not displaying, and it is exactly the same
  • The image types in both types of notes are png
  • An example of the links that are not displaying look like this:
    ![1548430735110](assets/20190125%20offshore/1548430735110.png). The displaying images have exactly the same style.
  • I have copied the same image to a new note and still is not displaying
  • If I open the non-displaying note with “Open with default app” and Typora, the note correctly shows the image.

What I’m trying to do

  • Displaying images in edit or preview mode. None of them works with the images

My OS is Ubuntu 20.04.


I found out what the problem was.

Obsidian doesn’t like big numbers as the alt-text. So there are several workarounds for this:

  • add a letter to the big number in the alt-text
  • just delete the big number and leave the alt-text empty
  • just use any name that is not only numbers
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.