Obsidian no longer recognizes specified font

Steps to reproduce

Open sandbox Vault.
Go to Settings.
Go to Appearance Menu.
Click “Manage” next to Text Font.
Begin typing desired font …

Did you follow the troubleshooting guide? [Y/N]


Expected result

desired font recognized and used

Actual result

it’s not available on the system according to Obsidian. In earlier versions, this worked, and I successfully selected my desired font (SBL Biblit Regular, in my case), and Obsidian was using it. But now, it says the font is not available on my system, even though it is installed and used by other programs.


Obsidian version: v1.3.5
Installer version: v1.3.5
Operating system: Windows 10 Pro 10.0.22621
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

Instead of choosing it from the list, does typing exactly SBL BibLit Regular in the font box and clicking Add let you choose it?

Screenshot 2023-06-21 081827

I am able to add an entry for the font in this manner, but Obsidian has a warning symbol next to the entry which says “This font is not detected on your system.”

Hmm. Not sure.

I just (again) downloaded the font from SBL Educational Resources → installed it via the mac’s Font Book app → restarted Obsidian → it was available to use in Obsidian.

I tried on Windows before and it also worked (screenshots in previous post). Both SBL BibLit Regular (capital L) and SBL BibLit seem to work for me.

This seems to be an Obsidian issue because:

  1. the font remains active on the system and is usable by other programs (e.g. Word)
  2. this is not the only font with this issue. I am experiencing the same problem with Jetbrains Mono

I was able to resolve this issue by:

  1. uninstalling SBL BibLit
  2. redownloading the font
  3. re-installing the font
  4. restarting Obsidian

Obsidian now recognizes the font, but again it was the only program I use which had this problem.

Back to the same problem. Obsidian is no longer recognizing SBL Biblit, even though it is installed on the system.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.