Obsidian app not available for iCloud

Things I have tried

Looked around for solution on this forum but not found one for my case.

What I’m trying to do

I’m trying to sync my Obsidian vault files with iCloud on Iphone (OS version 15.3.1) but Obsidian application is not listed as Icloud application for syncing at all. Found a couple entries here suggesting to turn both on, but unfortunately can’t be done due to that reason.

When creating a new Vault i get “You cannot access or create vaults in icloud because it’s disabled for obsidian”.

Appreciate help on this one, switched from Evernote recently to try out Zettelkasten approach and really liked is so far but moving files between my desktop and mobile is a little bit painful.

The vault needs to be in iCloud Drive. There is information about it here:


@_Dan, tried that already. While creating a new vault i cannot “Enable Store in iCloud” option mentioned in the instructions because i have it grayed out with accompanying message “This Option is not available right now because iCloud is disabled for Obsidian”.

Am i missing something ?

I wonder… are you trying to use Obsidian Sync to sync? (i.e. turning on the Sync options in settings). If so, don’t. Try following the instructions again and rather than thinking you’re synching, thing of it as accessing the same files from a desktop/laptop and from a mobile. iCloud is doing the syncing of what is in your iCloud Drive rather than Obsidian.

Obsidian is a paid for service (which I’m sure is great). Using iCloud Drive to access files within a vault from two or more devices is something different and perhaps best not thought of as syncing.

I believe we are thinking the same. I see iCloud in this case as an itermediary between my iphone and desktop computer providing storage location for all Obsidian notes. If i work on iphone i would expect all updates to be saved there, the same for desktop computer. Piece i’m missing is a configuration of Obsidian and iCloud to see each other on my iphone. Currently Obsidian seems not to be compatible with iCloud as it does not show on a list of iCloud apps on my iphone at all (solutions to similar problems i’ve found on this forum indicate that it should be there).

I believe Obsidian developers handled both services integration (it works for other users) but for some reason it doesn’t work on my end.

I guess that “as it does not show on a list of iCloud apps on my iphone at all” you mean that there is not an “Obsidian” folder in your iCloud Drive top-level folder. It’s in here that fault/s live.

I’m very sorry but I don’t think I can help. I do use iCloud Drive to store my vault and can access my files using Obsidian on a laptop, a desktop, and my iPhone. I don’t have any strong recollection of the initial setup, other than it involved creating a vault on my iPhone first and then accessing it from my Macs.

Sorry I can’t help more. I’m tempted to have a go at starting over to see I can see what might be missing for you, but fear that I might not get things back working again!

But it certainly was straightforward for me. If it isn’t for you, it might be an idea to delete the mobile app and start over with a fresh download. I guess it couldn’t hurt to try.

Good luck.

I’m no expert, but perhaps this is a permissions issue. You might try Settings on your iPhone, going to Apple ID (should be at the top in Settings), then iCloud, and scroll down to Obsidian and see if the toggle is on or off.

No worries @_Dan, appreciate willingness to help. It may be related with security on my phone. @mbbcam , i don’t see Obsidian application for toggling at all in iCloud menu of my iphone (that’s the gist of the problem in fact)

So you get that error when you create a new vault with this switch set to On?

@2fifty6, i don’t have Obsidian option to toogle on/off for iCloud at all. Obsidian app is not listed as iCloud compatible.

Very odd. I would delete Obsidian completely from my phone, switch off my phone, wait about five minutes, switch on, and download Obsidian again if I were in that situation. If that doesn’t work, there must be something odd about the iCloud/Apple ID settings of your account – or perhaps some limitation in whatever geographical region you live in.

@mbbcam , tried reinstallation and a couple of different regions through vpn, no change. Trying now to reach our internal corporate support team to look into it.

Can you share a screenshot of the “create a new vault” screen in your app? (Like what I shared earlier.)

My immediate thoughts (having a corporate provided iPhone as well as my personal one) is that the phone is intentionally restricted from certain things; Could it be that iCloud Drive is not enabled generally?

Ah, good point. If it’s a company-managed device, that’s very likely the source of the restriction. @Woyt, working with your corporate IT folks is probably your only recourse.

Still waiting for the input from support. @2fifty6 , here is a printscreen of message i’m getting

And Obsidian isn’t listed in Settings among the list of apps using iCloud?

Exactly. Would love to see what you have there on my end :slight_smile:

It was in fact our support blocking something on their end. Interesting, that they made it available for Obsidian (and a couple of other apps) recently but said it shouldn’t be used for external applications :(.
Thanks everybody for trying to help out !

1 Like

Glad to hear the mystery was at least solved!