Obsidian Android app login failed (on some non-goggle store devices)

After updating to version 1.4.16, I can log in to my account on PC, Mac, iPhone, and obsidian.md.

Only the Android app shows “Login failed, please double check your email and password”.

I followed the steps in “Can't log into sync on mobile [Bug] - #3 by joethei” and it still doesn’t work.


i have the same problem. I can not log in to the Android app.

I have already uninstalled and reinstalled the app - without success. Even with an older version it does not work. On the laptop and obsidian.md it works.

Is there already a solution?

Are you sure you are using the correct password? (input it manually if you are using a password manager)

What is your phone exactly?
What is the webview version installed (check in play store?

Do you have network problem? Does it work if you use mobile data? Does it work if you use wifi?

Yes, the password is correct. I have entered it several times. It works on the laptop and obsidian.md.

I have the problem on my Huawei Mate 40 Pro and my Amzon Fire Tablet 8"
I can’t find any information about webview in the playstore.

The whole thing has also worked before. Only then I changed the password under obsidian.md and since then I can no longer log in on the Android devices. I have done at obsidian.md also already from all devices. Browser data I have also deleted.

It also does not work via mobile data.

How did you install the app on these devices?

Is it possible that your autocorrect is interfering with the password input?

Change the password again with a simpler one and try again.

The apps were installed normally via the Playstore. They have already worked.

The autocorrect does not change anything. I made sure that everything was correct every time I typed it in.

I have now changed the password to a simpler one, but also without success.

I now have Obsidian installed on an Android phone that didn’t have it installed before, and that’s where I can log in.

On the iPhone, changing the password also worked.

Only on the two devices mentioned above it does not work.

What is the Android webview version?

Is there a Google PlayStore on Hawei and Amazon devices?

I am having the same problem.
I am on the Huawei Nova 9 SE, it has i think not google services, it runs on emui 12 and has huawei webview, i have tries changing the password to a simpler one, using a different keyboard, stopping the app and clearing the cache but nothing still. I have no Google Play store so i use Aurora Store, a app store intended to be used as a playstore privacy front end.

The Fire Tablet has webview version 118.0.5993.80 from 10/16/2023 installed.

The Huawei does not have a Google Playstore. Here also use the Aurora Store.

What I just do not understand, it worked until the time I changed the password.

The issue was fixed on October 25th, please try logging in again.

I sent a email to [email protected] with a screen recording of the operation. I received a reply that the issue was fixed on October 25th.

Thanks to everyone at Obsidian, I bow in gratitude. :kissing_smiling_eyes: :hugs: :rose:

1 Like

Great. Now it works again as it should.

Thanks for the support.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.