Obsidian 1.0.1 won't start

Obsidian 1.0.1 won’t start for me. I get the following error and then the UI hangs:

Things I have tried:

Reinstalling Obsidian: Didn’t work, got same error.

Deleting my .obsidian folder for the vault: Didn’t work, got same error.

Deleting the .config/obsidian folder: Worked (effectively downgrading me back to 14.16), but upon re-upgrading back to 1.0.1 I got this error again.

Manually downgrade to 1.0.0: Worked, but when I upgraded to 1.0.1 it broke again.

Here is my debug output from 1.0.0:

Obsidian version: v1.0.0
Installer version: v1.0.0
Operating system: #58-Ubuntu SMP Thu Oct 13 08:03:55 UTC 2022 5.15.0-52-generic
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


You are not the only one facing this problem. The problem has been reported to the developers already.

In your case, I would recommend to delete (again) your .config/obsidian folder (it should already be enough to delete the “obsidian-1.0.1.asar” file - at least this worked for me), restart obsidian and temporarily deactivate “automatic updates” and “get insider builds”.

What is more, I would strongly recommend to update your installer version to 1.0.0!

Thanks @alltagsverstand ! I’m glad to hear the devs are aware.

I rolled back to 1.0.0 (including the installer) and I’m up and running again with auto-updates disabled for now.

Hotfix v1.0.2 is out - quoting Licat from Discord:

  1. If you’re on 1.0.1 Linux and it errors out when you boot the app, quit the app entirely and restart. If it’s not fixed then wait 5 minutes and quit and restart again - it should automatically update to 1.0.2 with the crash fix!

1.0.2 fixed the problem for me. Thanks all!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.