Notes keep emptying themselves

What I’m trying to do

So the content of my notes keep randomly dissapearing in fron of my eyes. Let’s say I write a note, I leave it, I come back and it’s almost alway completely empty. Then I can hit cmd + z to restore it just for it to become empty again in several minutes. Today My note that emptied itself 5 times or so became corrupted. When I try to open it it says “no such file or directory”.

Things I have tried

I disabled all the plugins, the problem persists. It makes Obsidian unusable which is a shame because I love the concept.

I’m on Mac OS Sonoma 14.0 and lates Obsidian v 1.4.16

Here’s some screenshots of my problem:

Note keeps dissapearing (hitting cmd-z restores it):


Today I can’t open it att all anymore:

I’d appreciate some help!

1 Like

Is your vault stored in a cloud syncing tool, or some kind of network location?

  1. Can you post your “Show Debug Info”?
  2. Can you tell us where your vault is stored exactly? (Hide any private details like username.)
  3. Do you use Obsidian Sync?
  4. Did you try restarting Obsidian after disabling all plugins?

I have the exact same problem and it is driving me mad. It just happens to active and recently changed notes, I think. I have not found any other empty notes so far, which I have not seen in a while. But it happens every couple of minutes sometimes.

I save my obsidian folder on my Mac and with iCloud sync. Could that be the problem? But why only sometimes?

Here is my Debug Info:

Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.1.0: Mon Oct 9 21:28:12 PDT 2023; root:xnu-10002.41.9~6/RELEASE_ARM64_T8103 23.1.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 2
1: Emoji Toolbar v0.4.1
2: Calendar v1.5.10

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.