Not able to embed images in notes

Hello, I’m new to this community.

I am facing problem with embedding images within notes.

When I copy and paste images from the net (the URL is pasted) tentatively I can see the image in preview mode. But after a few hours I can only see the thumbnail icon. I have no dots or other characters in the file or folder name whatsoever.

The main problem that I’m facing, is that if I download the images in a local folder on my PC and try embedding that in any note, it doesn’t happen. When I drag and drop the image in the note, nothing happens. When I copy the image and try to paste it in the note by left clicking, the paste option is disabled

However, the images do get embedded in any note in the ‘Obsidian Help’ Vault. But that doesn’t work for any other vault.

I’m using a Windows 10 laptop and I recently updated from version 0.11.3 to 0.11.5 but in both versions, the issue persisted. I’ve tried creating new vaults and tried embedding images but to no avail. The images that I was trying to embed were jpegs and pngs. Dunno whether it’s a bug or what.

Any inputs?

1 Like

post a screen recording when you copy the image from the local pc

The paste option doesn’t work

I can’t access the files.

Hope they work…

It brings you to a “Access Denied, Request Access” page. I requested access, but I don’t use Windows, so I might not be of great help.

It seems like it might be some kind of a permissions problem.

  • What is the path to your vault?
  • In the settings there is “Default location for new attachments”. What do you have set in this setting? If you chose a path, is it a valid path that exists that you can write files to?

I’m sorry…the video goes beyond 4mb, so I had to send Google drive links. Don’t know why they’re not working.

I save my vault in the documents folder on my pc, if that’s what you mean.

Under file & links settings, the default location for new attachments is set to ‘vault folder’

Should I change that?

Tentatively, changing the attachments folder path has solved this problem. By setting a separate folder for attachments within the vault, I can attach the images by linking to the attachment using double brackets. Copy paste and drag and drop still don’t work, but at least I’ve found a way around it. Thanks a ton!

That still sounds problematic, and worth investigating and solving. Being able to copy/paste and drag is very convenient, and should work.

When you chose an “Attachment folder path”, does that folder already exist? Did you make the folder first? If not, if you DO add the folder, does it begin working?

I made the folder first. Copy paste and drag and drop still don’t work :pensive:

What is the path to your vault? If there is no private information in your path, can you paste it as it is, exactly?

If you can’t paste it, are there any non-alphanumeric characters in your path? (language accents for example).

I don’t really know how to use the developer tools. In the menu View → Developer Tools. Inside there, if you click on “Console” there may be a chance you see some errors or warnings about why it is failing. (Maybe not.)

One other question, just in case: What installer version of Obsidian did you use? If you look in “About” you’ll see “Current version:” and “Installer version:”

There were some releases a long time ago, where it was necessary to reinstall with a more recent installer to enable new features.

@abcake_69 It seems like there are a few people who may be experiencing trouble by using their Documents folder as their vault. (Super not recommended!)

Did you use C:/UserName/Documents as your vault?
Or did you make a folder inside C:/UserName/Documents/YourVaultName as your vault?

If you are using “Documents” or “My Documents” directly, that might be the cause of your problem.

No, I have a folder inside documents
C:/Username/Documents/My Vault Name

I had uninstalled and reinstalled obsidian before posting on the forum to check if the problem subsides. But the issue persisted

You took a photo of the entire developer tools, so I’m not sure if you noticed, but the error does seem to be there!

Uncaught (in promise) Error: EPERM: operation not permitted, open 'C:\Users\your\path\Just cotton.png'

Can any programmers interpret this? It seems at first glance to be a permissions problem.

No, but it seems to be the same issue as this thread: Help, Obsidian stopped working on my pc yesterday

Hi, I am having the same issue. Did you find a solution? I only have one folder on a shared drive as vault, and it’s specifically images that are giving me the trouble.

  • Can you give more info about what you mean by “shared drive”?
  • Do you get the same error in your dev tools view?
  • Have you tested making a vault in a regular local folder to see if it happens there?
  • What OS? And what version of Obsidian? And what installer version?

Hi, yes, sure, I was hoping that’s a bug that everybody knows :slight_smile: Thanks for looking into this.

My configuration is (overly complex): hard drive of a desktop computer which is shared on home network. Obsidian vault is one of the subfolders. Two laptops have Obsidian installation that uses this vault. One more laptop has a local vault which syncs with shared drive folder via SyncThing. All computers are Windows 10.

Error: Failed to load resource:net::ERR_FILE_NOT_FOUND.
This only happens with images, regardless of vault subfolder. Eg. PDFs located in the same place open within Obsidian without issues. I am able to open these images from Windows Explorer from the same computer that Obsidian is installed on.

I don’t have this issue on a laptop that has a local vault (synced to the shared drive vault).

On all laptops the Obsidian version is 0.13.31, installer 0.11.13, and OS is Windows 10.

So… personally I don’t know, and can’t help really.

  1. But silly question: When specifying your attachments settings: What are your settings? And if you specify a folder, did you use the auto-complete, or type it manually? When typing the path, you should see a dropdown of matches, and then you can select the match to make absolute sure you don’t have a typo.

But I doubt that’s the issue. This seems more like a permissions problem of some kind. …probably?

  1. In the latest Obsidian, if you hold Alt while dragging an image into Obsidian, it pastes a full path file:/// link to the image on your filesystem. If you drag the image from the vault folder where it is failing, does that work? (Not as a solution, but as a test.)

  2. It might be worth updating Obsidian to the latest installer. There may have been some major updates to CodeMirror. I haven’t kept close track of that.