Non-scrolling search highlights in overflowing embedded note

Steps to reproduce

  • Embed a long note with ![[long-note]] that causes overflow and a scrollbar.
  • Switch to reading-mode (it won’t work in live-view!)
  • Press Ctrl+F to search for a string inside the embedded note.
  • Scroll and observe the highlighting

Expected result

I expect the highlighting of the search-matches to scroll with the note.

Actual result

However they will not move. This bug makes it impossible to accurately search for strings in the lower part of the embedded notes (without opening the note itself, of course).

Environment

  • Operating system: Linux Fedora 34
  • Debug info:
    Obsidian version: v0.13.19
    Installer version: v0.12.19
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: off
    Plugins installed: 9
    Plugins enabled: 9
    1: Citations
    2: File Explorer Note Count
    3: Sliding Panes (Andy’s Mode)
    4: Templater
    5: Paste URL into selection
    6: Hotkey Helper
    7: Pane Relief
    8: Jump to link
    9: Note Refactor

Additional information

Here’s a screenshot with search-query “lorem”, which appears 3 times inside the embedded note.

EDIT: Maybe this can be solved right along with this bug that is also related to overflowing embedded notes.

Thank you very much!

Thanks

1 Like

I had the same problem with long note (not embedded). The reason is “indentation guides”. After turn off the “Options|Editor|Display|Show indentation guides”, the search works fine.

I have a similar problem on PopOS, Obsidian 0.14.15 thru 0.15.6 with an approx 1760 line file, nothing embedded, Indentation Guides turned off. The highlighting is in the right place on a subsequent Next search, but after Next, the scrolling jumps, but to several lines above the highlighted search hit, outside of the window bottom. I have to manually scroll down several lines to see the search hit. Haven’t found what syntax in the file might be causing this.