No value front matter key (only "-" present) displays as "[null]" in properties

Steps to reproduce

  1. Add some front matter:
  2. Make sure the property type of custom: has been set to List (multitext) via the properties.

Did you follow the troubleshooting guide? Y

Expected result

Like for the default keys tags: and aliases:, when only - is present (with or without whitespace following), show Empty for custom:, not [null].

Actual result



	Obsidian version: v1.4.14
	Installer version: v1.4.14
	Operating system: Windows 10 Pro 10.0.22621
	Login status: not logged in
	Insider build toggle: off
	Live preview: off
	Legacy editor: off
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

[null] also displays in the properties for any YAML key if given the value “-”, which may or may not be expected, e.g. custom2: -. When - is the start of an empty item, i.e on a new line, it should be interpreted as Empty I think.


ok, thanks

Will be fixed desktop v1.4.15

1 Like

Thanks @WhiteNoise. If you get the chance, can you look into why dropping attachments into a properties field doesn’t show up as a link (and therefore the local graph too)? The leading ! is a problem.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.