New plugin: Citations (with Zotero)

Hey all,

I’ve been using this plugin in conjunction with zotero for drafting my thesis. It’s incredible! Being able to easily cite materials is a game changer.

I primarily tend to draft in Obsidian. I insert markdown citations with a hotkey I set up, and then I export to .doc using Pandoc (shoutout to the Obsidian pandoc plugin). Uhh… Oh, I also use pandoc quick citations, so I’ve altered the markdown primary citation template to look like this: ^[@example citation,

My questions is, I think, a fairly simply one:

Is there any way to get the text cursor to appear AFTER the citation when I enter a markdown citation? As it stands now, when I enter a citation, the cursor stays at the point of insertion (before the carat at the beginning of my citation). I then have to manually move the cursor to the end of the line (after my comma) to write down page numbers for that specific reference. Then I close the citation with the final two ]]

I’m hoping for something a little more like the zotero plugin for word. I simply select my citation and then enter the page number. But for now, I’m ok with manually entering the final two brackets after the page number myself. It’s the cursor that is throwing off my work flow.



This plugin is great! Thank you so much for creating it.

Question 1, I solved it by saving my .bib file inside the vault, which is backup in Dropbox. Instead of writing the full path (absolute path), you can write just the name of the file in the vault.bib (relative path) and it will find it.

However, I still don’t know how to solve question 2, adding to that:

Is there a way of updating all the reading notes created with the plugin after updating the plugin’s template?

I set my .bib file to keep updated with Zotero, but sadly, it is not working.


Hi, somehow I can’t open Zotero’s saved PDF file from Obsidian. I added this line to the template [PDF]({{entry.files.[0]}}) which looks fine but when I click on the PDF file, I received an error from windows stating “You’ll need a new app to open this link” even though my PC has Acrobat PDF installed and it has always been my default reader since day 1.

Iˋm also having this problem. Iˋm using a Galaxy Tab S6 Lite. It shows the same message, so I canˋt open the plugin settings

I also encountered this problem. I current walk around is pressing keyboard {End} to go to end of citation.
However this will only work when you insert citation at the last part of line, which is usually my work flow.

I have the same issue and have not managed to solve it yet or to pinpoint the source of the problem. Did you fix it?

So I have Citations working well enough to where I can load metadata and my annotations notes from Zotero into a new note I call a “Reference Note”. Does anyone here know how to use Obsidian’s “Templater” plugin to automatically create a “Literature Note” based on the metadata from my “Reference Note” when the reference note is created? This thread has some decent information but I’m not sure how to implement.

1 Like


thanks for the plugin @jgauthier, it makes obsidian so much more useful.

I just encountered a small problem: For the template, I access author names by {{#each}}…{{/each}} which works perfectly fine. Doing exactly the same for editor names (e.g., for books), like this {{#each entry.editor}}…{{/each}}, does not work. In the bibtex (and the json) file from betterbibtex the structure of editor entries is exactly the same as for authors.

Any ideas?

Howdy y’all. I’d like to put the what is called the “Item Type” (book, journal article, etc.) in Zotero into my Obsidian citation. I’ve searched this forum and I’m still confused on how to make this happen. I’ve tried editing the literature note template with this placefiller but it didn’t work:
Item Type: {{itemtype}}

Any help would be appreciated!


As far as I understand, this is solved by using “entry.type” (as long as the type is saved in the entry). In theory, you should be able to access any bibtex entry by using “entry.”.


Hi! Congratulations for the “Citation” plugin!
I would like to know: is there a way to open a PDF stored in Zotero directly from a link in Obsidian?
Another question: I’m not being able to import URL link of the file from Zotero using the option BibLaTeX. Any suggestions?
This would be great!
Thank you!

@JamesKF Do you Solve the problem?

Hello, I am getting the “Unable to load citations. Please update Citations plugin settings” when trying to link this plugin to a .json that is stored in my Obsidian directory. I have Citation database format set to CSL-JSON.

OS: macOS Monterey 12.5
Obsidian version 1.0.0
Plug-in version 0.4.5

Hi, I can’t import my Zotero notes into Obsidian using the Citation plugin. I tried different formats (Better BibLaTeX, Better CSL JSON), but none of them work. Could you please help me figure out what I am doing wrong? Thank you in advance!

Hi, I have found this amazing plugin and want to thank you, but there is only a problem I can’t manage to solve, when I use {{entry.files.[0]}} the path of the pdf that’s returned starts with C\: and when I click to the link Obsidian can’t find the file. If I manually change it to simply C: it works fine.
Do you have any idea on how I can avoid this problem?


@jgauthier :

Feature request : recognize and open literature note based on a field in the note

Problem description

In Literature note title template, I don’t use something simple like {{citeKey}} or {{title}} as a title for my Obsidian note. But something like DOC_TYPE YYYY-MM-DD {{title}}, where DOC_TYPE is a special character that quickly indicates if the document is a book, paper or article (this was inspired from Bryan Jenks Obsidian Workflow).

I have not found a way to automate the DOC_TYPE part, so this is added manually in the title after opening the note with citation plugin.

The problem is that whenever I open the note again with citation plugin, it does not recognize the title anymore.

Possible solutions

  • Look for a field in the note (e.g. : itemID, citeKey, title, etc…) and open the corresponding note.

FR on Github

1 Like

Hello, apologies in advance if this has been already covered, but I couldn’t find it.

For some reason, the citation key in Zotero has changed, which means that now I risk generating duplicates in Obsidian when I insert a previously-inserted reference through the Citation plugin.
I have then decided to shift away from @{{citekey}} in the literature note title template, and use a different format.
Is there any way I can automatically update the previously-generated Literature note files to this new format?

Thank you

1 Like

It would be great if this plugin could work on mobile. Even if we can’t add new sources, it would be so helpful to be able to at least access the sources already loaded.

Is the plugin able to render citations currently?