New plugin: Citations (with Zotero)

I see. Thanks!


Great plugin, thank you for taking the time to put it together and develop it.

Just a quick question - I cannot enable it on iOS - I presume this is expected behaviour? Is there any likelihood of it working on iOS in the future?

Thank you again,


1 Like

Hi! I would like to know how can I have my citations in differents SO? I have a Linux Laptop and a Windows PC. The problem is that I use Obsidian in both systems and my notes are synchronized in the cloud. So, How can I configure the Citation database path for them both to work as expected?

I think you could specify the path as relative in the vault, I use mac and linux so both are unix-like, but Obsidian probably handle the path between Win and other OSes well; if you have a problem with nested path maybe try to put your citation in the root of your vault?


Thanks i will try that

I think making citations into links could ideally be a customizable setting that you could choose to enable or not. Sometimes having all those extra links could make things messy, but at other times it would be really nice to trace citation links from a text, put them on a graph etc.

Zotero-Citation plugin is so handy! Thank you!

Is it possible to insert the fields ItemType (Journal article, conference paper, thesis, etc) and DateAdded in the template? Having a way to connect the source to the daily notes page, and being able to filter the graph using ItemType as a tag would be super helpful!

1 Like

Is it possible to insert the fields ItemType (Journal article, conference paper, thesis, etc)

I believe this is entry.type

1 Like

I hope such a feature be in the road map:

1 Like

Currently, is already possible to embed PDF files from vault into Obsidian

I’ve encounters two problems with this plugin:

  1. (a minor bug) if entry do not have citation key, and you decide to use a citation key as a title for a new note, a note with no title is created. I don’t think that this is how it should work (Obsidian do not allow this);

  2. (a serious problem) I have exported my Zotero library, but many of the books are not visible in the Obsidian. Here are examples of such entries:

    title = {Prawo i Rewolucja},
    author = {Berman, Harold J},
    date = {1995},
    location = {{Warszawa}},
    annotation = {ZSCC: 0000048},
    file = {C:\Biblioteka\1 - Angielskie\2014\Berman - Law and Revolution, II The Impact of the Protestant Reformations on the Western Legal Tradition v. 2 2006.pdf;C:\Biblioteka\1 - Angielskie\2014\Berman - Law and Revolution, The Formation of the Western Legal Tradition 1983.pdf},
    keywords = {$LAW,read,TODO}

    title = {Rights and the {{Sovereignty}} of the {{People}} in the {{Crisis}} of the {{Nation State}}},
    author = {Brunkhorst, Hauke},
    date = {2000-03},
    journaltitle = {Ratio Juris},
    volume = {13},
    pages = {49–62},
    issn = {0952-1917},
    doi = {10.1111/1467-9337.00139},
    url = {},
    file = {C:\Biblioteka\3 - Artykuly\QR\Ratio Juris\Brunkhorst, Hauke - Rights and the Sovereignty of People.pdf},
    keywords = {$INTERNATIONAL_RELATIONS,$LAW,$PHILOSOPHY,human rights,nation state,read,sovereignty of people,TODO},
    number = {1}

    title = {Prawomocność},
    booktitle = {Przewodnik Po Współczesnej Filozofii Politycznej},
    author = {Flathman, Richard E},
    editor = {Goodin, Robert E and Pettit, Philip},
    date = {2002},
    pages = {674–681},
    publisher = {{Książka i Wiedza}},
    location = {{Warszawa}},
    annotation = {ZSCC: NoCitationData[s9]},
    keywords = {+concept,$SOCIAL_&_POLITICAL_PHILOSOPHY,legitimacy,read}

You should rather report this on github.

What do you mean exactly by “not visible”?

when I press CTRL+SHIFT+O, a search panel for Zotero entries opens. Many entries from exported Zotero library are missing.

It is difficult to say what’s going wrong without further information.

Most important question: Are you using BetterBibtex for exporting your Zotero library? If you have exported your library using Zotero itself, be aware that this is only a one-time-export and the resulting bib file isn’t updated automatically!

If the answer to this question is “yes”, some further questions might help:

In Zotero:

  1. How do your betterbibtex settings look like?
  2. How have you configured automatic exports in betterbibtex?

In Obsidian:

  1. How do your citation plugin’s settings look like?
  2. Does your problem only appear with recently added literature entries?
  3. What is your obsidian version (including installer version)?
  4. Have you updated the citations plugin to the most recent version?
  1. Yes, I use BetterBibtex for exporting. the settings are default, I haven’t changed anything.

  2. No, I’ve just started using citation plugins. Tried to reinstall it, exported file again, the problem still appears.

  3. Obsidian ver. 0.12.3
    Installer ver. 0.10.1

  4. Yes,

I’ve just tried exporting library in json format, and it worked (all zotero entries are avaliable from Obsidian)

Happy to hear this! :slightly_smiling_face:

Yet, still wondering what has been the problem before. Have you stored your json export in the same directory as before (.obsidian/)? Have you, alternatively, tried to store your bib file in a non-hidden directory and give an absolute path to it in the plugin settings?

In addition I would recommend to update your installer version! 0.10.1 appeared around the same time when the citation plugin has been released initially - thus, a couple of updates the plugin has experienced since then might possibly depend on more recent versions of obsidian…

1 Like
  1. yes, I’ve stored both exported libraries in the same directory. Moving bibtex file to another folder didn’t help
  2. Updating the installer dind’t chnge anything here.
  3. You may try adding manually the entries I’ve posted above to your bibtex file, and check if Obsidian sees them.

Thank you for your guidance :slight_smile:

I did some testing and realized what the problem is:

You can’t use the “$” symbol in bibtex (it is included in some of your tags). If you want to use it, it has to be escaped by using \ - cf. also here.

Oh, thank you :slight_smile: