New plugin: Citations (with Zotero)

Hello friends,

I am having an issue that I could not enter out the reference that was successfully loaded to Obsidian. For example, when I typed a reference (Pic 1) and ‘Enter’, it did not show anything on the file… (Pic 2). It is Better JSON format.

Could you please let me know how to fix this? I got a warning alert saying that I don’t have a folder to store or something but could not capture the screenshot as it disappeared :frowning:

Big thanks!

Pic 1

Pic 2

Did you try to go to the settings of the plugin and configure output folder so you were sutre it exists?

Thanks a lot. I just added a path to a folder in Literature note folder.

But it still keeps having the same error: “Unable to access literature note. Please check the literature note folder exists or update the citation plug in”.

The folder does exist but I am not sure why it keeps saying that error…

Could you please help me again?
Thanks.

I got it. I just created a folder in Obsidian and have the name of that folder in Literature note folder. :grinning: :grinning: :grinning:

Many thanks Daniel @echej

I am wondering if there is a way to automatically generate notes for all citations?
It’s just a small bother that breaks the thinking flow to have to manually create a new note for every citation…

Is there a way to give a new file name for the note?
Naming all notes with the default @{{citekey}} does not allow me to write 2 or more notes from a single paper. I am wondering if possible something like the Zettelkasten format: YYMMDD…
I have tried with some of the variables of this plugin, but each variable is unique for each article and they do not allow to create notes with different names. I hope I have explained myself, thank you!

EDITED: I already succeeded!
Instead of creating a new literature note, a new one from Zettelkasten is created and the content of the literature note is inserted.

Thanks @jgauthier! This is a seriously cool plugin! Makes it so easy to use obsidian for taking research notes!

I have a question. I would like to title the note related to a particular reading with <et al. if there are multiple authors (although I can do without this)>

Is it already possible to pick out the last name of the first author from the {{authorString}} parameter? If not, is there another way to do it or would you consider including that feature soon?

Thanks!

1 Like

Total Obsidian noob here so please forgive me for my ignorance.
I’ve spent a good while reading this entire through numerous times, the walkthroughs on using Zotero with Obsidian and watching the YouTube videos on the subject but I’m still struggling. Am I right in thinking that this plugin and integration with Zotero (using CSL JSON, Pandoc, etc.) now allows me to get Zotero refs via the search box which comes out (and darkens the note behind it) but not via the inline autocompletion way that Zettlr does? How close are we to getting a solution similar to Zettlr’s?

You may get
Crtr/Cmd + P (Command palette)-> insert citation
(you may define your own hotkey for that)

You may open also open note from vault in Zettlr (via tree dots menu), if you use the same bibliography file it shouldn’t be any problems

1 Like

Also if you have any question related to academic use of Obdidian join discord, there is a specific thread for use of Obsidian in Academia, you will get your answer much faster

This might be a useful tidbit to include in the README documentation on GitHub. I was kind of lost on how to employ the secondary Markdown citation format.

I’m looking for a solution for selecting the family name of the first author as well. Hopefully the advanced documentation would be updated to have some examples of this since I’m not able to understand it atm…

If anyone can help a bit that would be great!

2 Likes

I actually figured out how to do this. You need this expression: {{entry.author.[0].family}}

However, I still have to figure out how to create APA style in-text citations where it automatically becomes “FirstAuthor et al.” when there are more than 2 authors. It should be fairly easy to achieve this. If I had some javascript knowledge I would fork the source code myself but I really don’t have the time to figure everything out right now. I hope the author adds this feature in the future.

2 Likes

when i use {{year}} in literature note content template the number it shows is always one year less than what i input in zotero. it is good in citkey but only happens in template. any idea why it is so?

Hello! I know it’s been mentioned a couple times in this thread but I couldn’t quite figure out what I need–
I’m trying to figure out the filepath for the citation database path.

(full filepath I’ve entered is “~/projects/Life/Bib/small.bib”)
(Life is my vault)

When I first open the citation plugin settings, there’s no error on this filepath, but when I change it at all the error comes up. I am directing it to a .bib file, not just a folder.

I’ve been using a test “small.bib” with only one citation hoping it would make the loading process faster (I had it running for a couple hours at one point), but I assume mine isn’t loading because the file path is wrong.

So summary of my confusion: is there something wrong with my file format? If I’m getting the error message, should the error message go away if I type the correct filepath in, or do I have to keep trying and refreshing?

Thanks for the help :sweat_smile:

I guess the problem is the ~. Try to enter either an absolute path or /projects/Life/Bib/small.bib

1 Like

oh absolutely incredible! i assumed since that path worked in terminal it would work here, but alas. thanks for the help!

Have you tried using the mdnotes plugin?

I’m not using Zotero. I highlight in pdf and export the highlights with Adobe acrobat pro.

Hey everyone! I know most Obsidians use Zotero as they go-to reference manager, yet is anyone here that uses Mendeley and wants to share their experiences? I am trying to get whether I can include more variables in the Citations plugin, existing in the .bib files exported by Mendeley, i.e. “Journal”, “Keywords”, “files”, etc.