[Moblie] Bold text not working for Korean characters

Steps to reproduce

Starting from scratch, what are the steps to make the bug happen?
The fewer the steps, the better.
Type below:

  1. Open the Obsidian in Android phone.
  2. Type some text in Korean and surround it with ** or __.
  3. Preview the note and observe that the text is not bold.

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

The text should be bold when using the markdown syntax ** or __.

Actual result

The text is not bold when using the markdown syntax ** or __.

Environment

SYSTEM INFO:
Operating system: android 13 (Nothing A063)
Obsidian version: 1.4.16 (114)
API version: v1.4.16
Login status: logged in
Catalyst license: none
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 2
Plugins enabled: 2
1: Obsidian42 - BRAT v0.7.0
2: Bartender v0.5.9


Additional information

I don’t see this happening on the computer version - it seems to only happen on the mobile app.

When using English and Korean characters together, only English is bolded.

Bold seems alright on iOS.

Can you paste an example of the text here in a code block so that Android users can check? Also, if you haven’t yet, can you try in a new test vault?

Here is code:


기본
Normal

**볼드**
**Bold**

__볼드__
__Bold__

Screenshot:

Pretty sure the same occurs for Japanese. Rendering in reading mode is correct, but live preview and source mode are confused (they bold more than what will actually be bolded).

Occurs on iOS 17.1.2 with obsidian 1.4.16. Don’t have acces to a PC to confirm the bug there.

Example

For the example below I get the source mode seen in the screenshot.

> [!example] 
> * 日本人は会社**のために**よく働きます。
> * 私は日本のことを知る**ため(に)**日本へ行きます。
> * 外国人**のための**いい辞書がありません。