macOS Text Replacement doesn't work

Steps to reproduce

Add a text shortcut like ;;zet in macOS using the system text replacement which expands to…anything (or your note template).

Expected result

It should be picked up by the system and expanded to your text.

Actual result

Nothing happens


  • Operating system: macOS
  • Obsidian version: 0.6.7
  • Using custom CSS: 80’s theme stock

Additional information

This does not happen if you use the snippets feature in Alfred so it’s got to be specific to macOS and their text replacement system.

1 Like

Just for information: this is a known issue with Electron apps in general. Something to do with Electron not using proper macOS text fields.

Hrm, so there is likely no solution coming.

I think it can be worked around on the development end, but indeed, if your workflow depends on text expansion I would stick to Alfred.

Yeah, not going to do that since Alfred text expansion can’t sync back to my iOS devices (where I do most of my actual writing and note taking actually).

1 Like

Yes, this is a bummer! I tried with BetterTouchTools and implemented a / feature for a note template using /template and I can confirm their shortcuts work but the builtin macOS ones don’t work at all. Like you, my main reason for using the builtin ones is because it syncs with all my devices automatically so I don’t wish to add another app to my workflow for text shortcuts.

1 Like

I found these old reports if it’s any help

and a possible solution,


move to graveyard because it’s not our fault.