Lost changes from time to time

Steps to reproduce

  1. create a daily note
  2. type something

Expected result

my changes will be saved

Actual result

my changes disappears after couple seconds/minutes


  • Operating system: Win 10
  • Obsidian version: 0.12.15

Additional information

It started around the beginning of September. It worked perfectly fine before, but starting around 9/1, from time to time my changes just got reverted after few seconds after stop typing. It does not revert the entire document, but just revert some content that I typed in the past few seconds.

For example, if I type 20 lines at once, 10 seconds after I stop typing, the bottom 10 lines just disappeared. If I notice it fast enough and do control + z, then my changes go back. When I lost my notes, there’s a pop-up window on the top right that says "… merged … " or something but it disappeared too quickly and I was never able to read the full message.

And it only happens to my daily notes. I haven’t seen it in regular notes yet (probably also because I don’t use regular notes that often).

do you have other programs that work on your notes or sync services active?

Does it happen in safe mode (no third party plugins?


I am using Box for Sync. I haven’t tried the safe mode because I regularly use the day planner.

And just extra information, it does happen in non-daily notes as well.

If it’s an issue with the sync software (which I suspect more and more), what’s a good workaround? Thank you!

try to keep box off. If it doesn’t happen you found your problem.
I believe is box too.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.