Local links in Obsidian's Markdown?

Hello to everybody, thanks to the developers and to this community.
My question is about links to local files.

Is it possible to link a (huge) video tutorial from my NAS or a (huge) i.e. PSD file from my drawing folders without been transferred (and double copied) to the Obsidian’s attachments folder?

I cannot find a solution. It would be perfectly nice to incorporate some cell commands in Markdown (i.e. direct my player to open a specific video with the appropriate command line).

Any help will be appreciated. Thanks.


what I use (wo space, " or ‘’) to open the file:

Local file:
Doc: [:page_facing_up: description](file:///c:/…)

Network file: Doc: [:page_facing_up: description](file:///%5C%5Cnetworkpath)

File path to URI plugin.


Thanks for prompt response.

I tried the following (it worked fine):

jpg: [description](file:///D:\downloads\2021-01-26_151546.jpg)

jpg: [description](file:///D:\downloads\2021-01-31_220936%20Copy.jpg)

mp4: [description](file:///L:\nodisk1\Blender\Skillshare%20-%203D%20Illustration%20in%20Blender\24%20-%20blender-intro-24-conclusion.mp4)

(My NAS is mapped to L: drive in the last example).

The only problem is the %20 character for all those cursed names with spaces. I once used a utility that automated the copy of system filenames (by also inserting by substitution the %20 characters in all spaces).

Is there any quicker method?

I guess better to automatically rename the offending (with spaces) files is the preferred method and more permanent solution without future hickups.

Yes - enclose your file path in "<...>

For example:

jpg: [description](<file:///D:\downloads\file name with spaces.jpg>)


Sweet! Many Thanks.


<…> is really a good method, but could you suggest something to this problem with network file.
I have to use and convert %5C instead of . I would like to use the “Copy as path” method, but it gives \ back and your method doesn’t treat this.

I have no clue about working with network files. Which OS are you using? And isn’t there missing the server name in your path? I mean, shouldn’t it be like: file:///servername%5Cpath-to-file (or, converted: file:///servername\path-to-file)?

Yes, but in front of the server name, there are two \. Just I can not write it in.
So the path is: file:///\fileservername/…
The coding of \fileservername is %5C%5Cfileservername.
OS is Windows

Please see this thread for the network path solution: Using local server share links