Linux Middle Click Paste does not work 1.0.2

In version 1.0.2, pasting with the middle mouse button no longer works.

Steps to reproduce:

  • Click on something and try to paste it with the middle mouse button.

Expected result
The text to be added appears in the text editor

Actual result
Nothing happens

Environment

  • Linux (Debian 11)
  • Obsidian 1.0.2
11 Likes

This has not been touched yet but it will likely be disabled in a future release because it causes a lot of problems

Tanks for your quick answer!
Should this function be removed completely? As someone who does a lot of copy pasting I usually rely heavily on this functionality.

6 Likes

You can still use the normal copy paste.

That’s true, but it’s significantly more pleasant to be able to copy exclusively with the mouse than to always have to be at the keyboard with one hand.
Especially if you have a wireless mouse :=)
That’s the reason why Linux has this feature.
In addition, the copied data in the mouse is in a different buffer, which makes it possible (e.g. with Vim) to copy two different things at the same time.

9 Likes

use right click->paste.

At the moment, Obsidian is incompatible with middle-click copy on linux and as you have seen in the other thread we have quite a few angry users about it.
Hence, it will be likely disabled. If one day we can make it compatible, it will be enabled again.

1 Like

Right click → copy and paste unfortunately undermines the buffer feature.
:sweat_smile:
It is also much more comfortable to be able to select something and then paste it, rather than always having to right-click → copy and right-click → paste.

Is it considered that there is a checkbox that enables/disables the disable middleclick feature?

10 Likes

Same issue, Would be nice to have the option to enable / disable the middle-click, this is going to be a tough one to re-learn.

8 Likes

This is an unfortunate non-solution to the middle-click problem. As a long-time linux user, middle clicking to paste the current text buffer is an important UI feature that is now broken in Obsidian. I can not over-stress how important the middle-click-to-paste feature is to me when working with text files on Linux.

As an aside, the current version doesn’t even fix the only middle-click related issue that I had with Obsidian 1.0 - using middle click to close a tab still pastes texts from my buffer into the open document as described in Linux middle-click paste is problematic and needs to be automatically disabled - #20 by mleduc

My sincere hope is that this change will be reverted very soon and the Obsidian editor will once again behave like a native linux application with regard to the middle click.

10 Likes

I won’t pretend that it’s just a subject for a casual discussion or a matter of preference, because it’s actually not. It’s one of the CORE UI mechanics, you’re not assumed to touch it, like never.

Middle-mouse click has been my primary pasting gesture for about twenty years. Now you’ve basically rendered it broken. Obsidian is a text editing tool friends, where you use pasting all the time.

What worries me, is that it’s not marked a CRITICAL BUG yet. And having this guy in a release makes me think that you folks are a little out of touch with reality :slight_smile: Of course we love Obsidian! But I don’t think we’re enough tolerant to take this.

10 Likes

@WhiteNoise @moderators Please reopen the topic as a bug and remove the “Resolved help” tag, since the problem has not yet been fixed and has now been reproduced by others.

6 Likes

As @onkeltem, @urdvr and @Naming9789 have said, relearning (especially since the feature still works for the rest of the software in the Linux world) is extremely annoying.
After all, this is one of the features we love about Linux :heart:. (Not every Linux user, of course, but quite a few)

7 Likes

I have the same issue for version 1.3 - Is there any workaround yet?

1 Like

Since upgrading to the new version (1.0.3) CopyPaste with the middle mouse button stopped working

Steps to reproduce

Select something and try to paste it with the middle mouse button

Expected result

The selected text appears in the document

Actual result

The text does not appear in the document

Environment

  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v1.0.3
    Operating system: #1 SMP PREEMPT_DYNAMIC Debian 5.18.5-1kali6 (2022-07-07) 5.18.0-kali5-amd64
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 3
    Plugins enabled: 0

RECOMMENDATIONS:
none

Additional information

I tried it with enabled and disabled plugins, but it does not work in both cases.
Also I tried to use the newest installer version, but it does not work either.

2 Likes

Did you try searching the forum?

2 Likes

Well, it is another version, and the issue still persist on my machine. But thanks for the link.
So im not alone with this issue.

Did you read the discussion? Middle-click paste is likely to be disabled for the foreseeable future.

What i could read from this and this discussion is, that many people have a problem with this foreseeable future and the main isse (that the middle click disrups the ui) still exists, whereas the pasting feature in the editor stopped working.
Am I wrong about that?

1 Like

So even if I hate that future of Obsidian, at the moment it’s a bug.
Or am I wrong about that?

1 Like

MIddle click hasn’t been intentionally disabled. To fix another bug (on Mac) accidentally broke middle click/paste on linux.

There is the other issue that middle click on linux is itself very broken (even when it was working) https://forum.obsidian.md/t/linux-middle-click-paste-is-problematic-and-needs-to-be-automatically-disabled/34717.

The middle-click/clipboard paste will be reworked in 1.0.4.

7 Likes