Linux: create new vault?

What I’m trying to do

I’m trying to create a new vault.
(I’m using v0.12.10 on Ubuntu 16.04)

Things I have tried

I tried opening a new vault from the UI (Open another vault button above the Settings wheel), but the window doesn’t render. I see an outline of the window (a shadow effect) but nothing inside it.

Can I do this on my filesystem through terminal somehow?

I see that the vault location is defined inside the /home/<user>/.config/obsidian/obsidian.json file, like this:

        {"path":"/home/<user>/.config/obsidian/Obsidian Help","ts":1612902616793},

So I imagine I could potentially just create a new vault by editing this file… if it wasn’t for the hash, which leads me to wonder that this file is written to by some other program when creating a vault, i.e. editing this file is not sufficient to create a vault.

(Using grep I see that the 2 hashes appear in a binary .log file here: /home/<user>/.config/obsidian/Local Storage/leveldb/000003.log)

You should not have to use the terminal to do this. Also, I would not edit this file, it is written by the program, as you say.

If I understand correctly, you are Creating a vault, not Opening an existing one, correct? You need to create the vault before you can open it… try the “Create new vault” option instead. (perhaps the issue is deeper, but it’s best to start at the beginning :slight_smile: )

If this part of the UI is what shows as blank for you, it’s likely a theme and/or snippet interfering with the display. If you have any custom .css enabled, disable it and see if that solves the UI issues.

Please let us know if things get better!

@Erisred thanks for the quick reply! Indeed, I want to create a new vault, not open one.

Unfortunately that’s the window that doesn’t render. I haven’t activated any custom CSS or changed any settings.

Though I can’t see anything, by clicking around the “ghost window” I found that I can click the 3 buttons and the dropdown languages menu. The dropdown menu opens up, and the Open button opens a system file explorer (Nautilus on Ubuntu), but unfortunately the Create button leads me to another ghost window, so I can’t quite hack my way around it : /

I found a hack… If I click the Open button (or rather, where the button should be in the ghost window, because I can’t see it), I can “Open folder as vault”, essentially creating a vault in the process. However, if I want to open that vault again in the future I need to go through the same process of finding the ghost “Open folder as vault” button : /

@inigomdr - Unfortunately, if you have no other theme or snippets active, it sounds like you have an installation issue. You can safely re-install Obsidian without losing your data - it’s just a folder of files.
Just as an aside, are you using Snap install, or the AppImage installation? Snap is historically problematic, while the AppImage seems to be pretty stable.

1 Like

That was it! I had installed it from the .deb package. After uninstalling that and reinstalling from AppImage it’s working great. Thanks for the help!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.