Link autocomplete - unexpected behaviors

This morning I noticed that internal link autocompletion functionality was not working as it had in the past – or at least, as I expect (my memory is lousy so…)

(1) When I type [[ and the auto-complete list appears, I expect/remember that a mouse click on a suggestion like [[foobar]] would complete the link to the ‘foobar’ note. It doesn’t now. I also expect/remember that if you are hovering over a suggestion, a keyboard return would complete the link. It doesn’t. However, hitting a tab does complete the link…

(2) When I hover over a suggestion and attempt to search for a header or block-reference within the suggested link, the same things occur – neither a return nor a mouse click will properly complete the link.

Steps to reproduce

  1. Open a note in edit mode
  2. Type [[ to launch the auto-complete suggestion
  3. Hover over the desired note name
  4. Alternately, hit return or mouse click

Expected result

To create an internal link, simply type [[. This will prompt you with the list of notes you can link to. Use Up arrow and Down arrow to navigate the suggestion list and Enter to select the current highlighted link.

Assuming the desired note is called “foobar,” I expect to see the internal link to “foobar” created in the current note as [[foorbar]]

Actual result

Instead, I get empty double-brackets like this: [[]]

Environment

  • Operating system: Mac OS Big Sur 11.2.2
  • Obsidian version: v0.11.7

Additional information

Quitting and reopening Obsidian had no impact. :grimacing:
I was able to replicate using the standard “Help” vault which is in Safe Mode and has no community plugins, so I’m surmising it’s not a plugin issue.

It’s going to be fixed in v0.11.8 :smiley:

1 Like

Sorry, didn’t find that on my search prior to posting! Looking forward to the fix!