Latex equations placed in one line when switch to reading mode

When switching between reading and edit mode the latex equations get placed in the same line even though I write them in separate lines. This is also occurring on mobile as well I use a 2020 iPad pro 12.9

I am not sure I understand what the problem is from your screenshot. Post a minimal example in the sandbox vault and attach the file.

I can’t replicate the issue in another vault however I did attach the file from the sandbox vault and an image from my personal vault for comparison. In the sandbox vault, the equations are actually shown in separate lines. When trying to do the same thing in my personal vault the equations are combined together in one line which is not what I want to achieve.

images taken from personal vault
This image shows vault in edit mode and shows equations in separate lines

This image is in reading mode and combines equations into one line when I wanted equations in separate lines.

I don’t know anything about Latex, but in Obsidian settings → Editor → “Strict line breaks”. If you toggle that does it make a difference for you?

Otherwise, maybe this thread is related? Latex math newline line break \\

You have not attached the file and since it doesn’t happen in the sandbox vault. It’s likely some plugin or config problem. Moved to help section

Yes, after toggling the strict line breaks it fixed my issue. Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.