Kernel Panic on macOS 11 (crash, reboot)

I’m currently running into the same issue.

I don’t think I’ve run into this problem before, but it’s the second time it happens in just a few days.

I’ve send the crash report to Apple, but just thought it could be worth to mention it here as well.

@bright : in my crash report, it was also clearly saying this :

Process name corresponding to current thread: Obsidian Helper (Renderer)

As for the time it happened, I was testing the very new TOC Plugin from hipstersmoothie (GitHub) and I just had one note open.

I’m currently using Obsidian v.0.11.0 and as for my Mac :

macOS Big Sur Version 11.2.1

MacBook Pro (Retina, 15-inch, Mid 2014)
Processor 2,5 GHz Quad-Core Intel Core i7
Memory 16 Go 1600 MHz DDR3 
Graphics Intel Iris Pro 1536 Mo
Hardware Overview:

  Model Name:	MacBook Pro
  Model Identifier:	MacBookPro11,2
  Processor Name:	Quad-Core Intel Core i7
  Processor Speed:	2,5 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 Ko
  L3 Cache:	6 Mo
  Hyper-Threading Technology:	Enabled
  Memory:	16 Go
  System Firmware Version:	430.0.0.0.0
  SMC Version (system):	2.18f15

Edit : Happened one more time today few hours after writing what’s above :confused: .

1 Like

It could be possible that it because of electron . if you go on electron github issue page many people have filed issue for past 2 years on same kernel panic situation.

EDIT :
just had another kernel panic like 5 minutes ago

Process name corresponding to current thread: Obsidian Helper (Renderer)

never had issue with vscode or other electron app and now i am convinced it’s obsidian. Correcy me if I am wrong.

I’m absolutely no dev’ so I have no idea how all this works, but taking a look at the issues of Electron on GitHub, seems like there’s is something going on between Obsidian and Electron…

I’ve found a few ones quite similar (this one, for example) to the report I get when it happens.

@pch
I would like to hear what developer of obsidian have to say about it like if they are trying to resolve it or not. Because if you scroll up @WhiteNoise kept saying it’s apple court. If he is right and nothing can be done with this situation for mac user then i don’t think I will continue using this app. I love this app and literally can’t think about switching to something else but these crashes are serious and won’t touch it unless this issue is resolved.

Dev here, just want to let everyone know our side on this issue:

Kernel panics are never supposed to happen - when they do, it’s often a bug deep in the operating system’s drivers. Recently we’ve heard quite a few reports of issues with MacOS’s graphic drivers and unfortunately this isn’t something we can debug.

I understand some of you are reporting that this only happens with Obsidian, which has lead many to believe that it’s a bug with Obsidian. I’m not here to shift the blame to Apple or Electron, and we fully acknowledge that Obsidian could have been doing something MacOS doesn’t like.

For now, I suspect this might be either due to our graph view (which runs on WebGL), or plugins that deeply integrate with system level resources, such as running programs or using native NodeJS APIs.

Sadly, we are powerless to help. We do not have any members on the dev team who are professional MacOS native developers, who understands well enough how the OS works and knows tooling to debug this kind of issue. On top of that, this isn’t a reproducible bug that we can pinpoint to specific behaviors we can try to avoid from the application’s point of view.

Here’s my suggestions to users hitting this issue:

  • Report the crash to Apple. They are the only one in power to actually “fix” the issue, rather than finding a workaround. The more reports there are, the larger the signal to Apple this is a serious issue.
  • If you aren’t running the latest patch update for your OS version (Catalina, Big Sur, etc), consider trying an OS update.
  • Try to find some patterns. I know it’s hard and based on many reports here sometimes even leaving the app open could lead to a panic. But if you find anything helpful, we could potentially find workarounds that could potentially avoid touching the faulty driver.
  • Try disabling community plugins, and closing graph view panes. See if that helps.

To the guy that have kernel panics. does running obsidian with --disable-gpu help?

Today I’ll work with all community plugins and custom CSS disabled. I’ll see if it happens again.
Yesterday it crashed twice.

2 Likes

Thank you very much @Licat for taking the time to answer and clarify things a little bit.

Just to be clear, I really didn’t mean to blame anyone here, I was more thinking out loud.

I mentioned the trouble with the Obsidian Helper (Renderer) simply because it pin points directly Obsidian and as the no dev’ that I am, I just thought it could help a bit :woman_shrugging: (nothing more).

As for your recommandations, I’ll continue to send the report to Apple if it happens again (so far, today, no crashes in sight :grin: and Obsidian has been open for quite some time now).

I’ve disabled the very last plugin I installed (the TOC plugin, which I’ve got through the settings in Obsidian) but left the others as until yesterday, I wasn’t really aware of this problem so I need to try and return to my “previous” settings of Obsidian and see if it happens again.
If it happens again, I’ll sadly disable everything and try to investigate further :blush: .

Things I forgot to mention thought :

  • I only have one very small vault of 32,6 Mo (130 elements) on iCloud (so far)
  • 13 actives CSS snippets and I’ve used solely the default dark theme (for now)
  • 7 active community plugins and a lot of core plugins

I never use the Graph view while working on my notes as it always seemed, to me, not very “ressources friendly”. I open it when I’m done, at the end of the day, to see my “progress”.

I’m a fairly new Obsidian user, and I really think I’ve finally found the right note taking app’ for me. So, I find those kernel panics really saddening :slightly_frowning_face: .

I can only hope, I’ll be able to continue to use Obsidian like I did before and those crashes will “go away” :blush: . I’m not planning to abandon Obsidian anyway :blush: .

Quick question here though, just in case but how do you do that ? :innocent:

From the console: obsidian --disable-gpu or create a shortcut that runs obsidian with --disable-gpu.

This is not just an Obsidia issu if you search on github, you’ll find many other electron projects with the same issue.

1 Like

I’m really sorry if this is the feeling that came from my previous posts in this topic. I wasn’t trying to blame anyone but I may have not express it correctly.

I’ll definitively take a good look (this time) at the issues of Electron on GitHub though, see if I can find something useful there (who knows), or at least something that could help me to understand a little bit more where the problem might really come from :blush: .

Dully noted :+1: !
If I really need to, I’ll try it :blush: .

Thank you!

Since this is about macOS, it might be helpful for some who don’t know how to run apps on Mac with commandline arguments.

  1. Open Terminal.app
  2. Copy & paste the line below:
/Applications/Obsidian.app/Contents/MacOS/Obsidian --disable-gpu
4 Likes

Wait. Have we thought about theme and appearance settings in this thread?

Since it’s possibly a GPU issue I wonder if there’s certain CSS that mucks with electron+macOS…

@luckman212 : Thank you ! That’s pretty useful indeed as I never launched Obsidian from the terminal :innocent: !

I use and always have used the .theme-dark “Base theme” (so far) with translucent window on off.

As far as the CSS snippets go, I’ve got a few, but they are pretty common ones.

  • Styling the block quotes in Preview
  • Faint text when checkboxes are checked (instead of strikethrough)
  • Changed the font everywhere (Edit & Preview) + one specific mono font for codes
  • Changed the font-size of the footnotes (and references)
  • Changed the “flashing” highlight color when clicking on footnote/back ref.
  • Full color changes on the graph view
  • Changed the color of the ==highlighted text== (Edit & Preview)
  • Reduced the indentation in lists
  • Relationship lines for lists (Edit & Preview)

And that’s pretty much it :blush: .

Concerning the community plugins I use :

There was the very new TOC plugin, but I disabled it as I experienced a kernel panic while testing it (:confused:). The second kernel I run into yesterday was when trying to embed a TikTok video :laughing: .

As for the core plugins everything is enabled except :

  • Random note
  • Audio recorder
  • Workspaces
  • Publish & Sync

Not sure if any of this could help, but I didn’t run into any kernel panics today :grin: !

1 Like

Thanks for the thorough report. Hopefully we’ll discern a pattern sometime soon!

1 Like

This is all I’m hoping for too :blush: !
Thank you for trying @ryanjamurphy :blush: !

1 Like

Tried this yesterday evening, didn’t close obsidian over night and just had a crash and reboot.

I have a MacBook Air with M1 chip and I am on Obsidian v0.11 as well as MacOs 11.2.1. I use the Minimal theme, only a few snippets and a lot of plugins. I can share them if necessary.

Had 4th crash again on macos same details as before.
plugins :

  • advanced table
  • daily planner

using vim keybindings.
I don’t use graph view.
Theme :

  • red graphite

hardware :

  • macos big sur version 11.2
  • processor - 2.3 GHz 8-core intel core i9
  • memory - 32 GB 2667 Mhz DDR4
  • Graphics AMD radeon Pro 5500M 8 GB

NOTE : no custom CSS snippets

just giving some information so it’s easier for dev to track down the issue.

from now on i am keeping obsidian bare bones with no plugins and stock theme. Will report again if there is another crash.

2 Likes

Another one for me too here (2021-02-28 - 1:20 PM (UTC+1)).

Reported it to Apple (Just in case, I kept a copy of the report (same for the previous one too)) .

I didn’t have any yesterday (despite playing around with CSS Snippets and adding few plugins through Obsidian’s settings).

On the four kernel panics I encountered so far, 2 of them happened while adding external links to a note (between the copy of the link from Chrome but before being able to paste it in the note… in other words, while the link was still in my clipboard) :

  • When embedding the TikTok video (I was going to paste the link into an <iframe>)
  • And just now as I was formatting the markdown external link in my daily note ( []()) : It crashed while I was writing the text for the link [Foru] .

Each time I had just one single note open (solely in Edit mode).

No data loss so far and after reboot, Obsidian reopened exactly where it was left when the crash occured.
iCloud so far seems to be doing correctly its job :blush: .

As it’s the first time it happen in the past few days, I can say that :

  • I was able to add, update and or configure community plugins without crashes.
  • I’ve also been able to modify CSS snippets, test new ones (which I don’t use yet) and preview community themes without crashes, also.

But :

  • I didn’t do any “real” writings during those past few too (I’ve been in a procrastination phase :innocent: ), until now (even though it wasn’t much : just a tasks list of 94 words per Obsidian - 754 characters).

As for the rest, my Mac didn’t change in between my last post and now.

macOS Big Sur Version 11.2.1

MacBook Pro (Retina, 15-inch, Mid 2014)
Processor 2,5 GHz Quad-Core Intel Core i7
Memory 16 Go 1600 MHz DDR3 
Graphics Intel Iris Pro 1536 Mo
Hardware Overview:

  Model Name:	MacBook Pro
  Model Identifier:	MacBookPro11,2
  Processor Name:	Quad-Core Intel Core i7
  Processor Speed:	2,5 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 Ko
  L3 Cache:	6 Mo
  Hyper-Threading Technology:	Enabled
  Memory:	16 Go
  System Firmware Version:	430.0.0.0.0
  SMC Version (system):	2.18f15

I’m still not using any community theme and to my previous list of my enabled community plugins :

I’ve added :

  • Recent files
  • Vault Changelog

And also re-enabled the Table of Content plugin which was just updated today.

For the core plugins, nothing changed. Everything is enabled except :

  • Random note
  • Audio recorder
  • Workspaces
  • Publish & Sync

I’m not sure I can be more precise than this here :blush: .


Edit : Yes, I can add one thing :

Just in case, I’ve run a diagnostic on my Mac (to put aside some hardware problem, as it’s pretty old and used :innocent: ) and it came back negative : there was nothing to see there, fortunately :blush: )

2 Likes

After starting Obsidian without gpu with this command

Terminal gives back this prompt quite often:

Obsidian Helper (Renderer)[1319:30798] CoreText note: Client requested name ".LucidaGrandeUI-Bold", it will get Times-Roman rather than the intended font. All system UI font access should be through proper APIs such as CTFontCreateUIFontForLanguage() or +[NSFont systemFontOfSize:].

Maybe this helps

1 Like

Another one (4:45 PM (UTC+1))

This time I was playing with a CSS snippet concerning the relationship lines in Preview Mode, specifically :roll_eyes: .

I was trying to render relationship lines with lists containing different types of list (Bulleted list + Numbered list).

This lead me to discover that my CSS snippet concerning the relationship lines in Preview mode, literally break the scrolling when having a note open in Edit and Preview (with linked panes) at the same time :roll_eyes: .

I didn’t notice it before because I tend to scroll, when using linked panes while re-reading myself, in the activated Preview pane (rarely with my cursor in the Edit Pane) but today, for once, the activated pane was the Edit one and it looked like this (with the snippet still enabled) :

First with the Edit pane activated (which doesn’t works, as the preview pane jumps) and then with the Preview pane activated (which works)

And when I disabled the CSS snippet for the relationship lines in Preview mode, the scrolling trouble disappeared :

Yesterday, I thought there could be a relation between the kernel panics and my clipboard, today, thinking further, it just could be this scrolling trouble : I was in a task list when I tried to copy/paste my external link into my note yesterday and even if I didn’t have the preview opened at that moment, maybe this small bits of code was asking too much to the Obsidian Helper (Renderer) ? :woman_shrugging:

The CSS Snippet I used for my relationship lines comes from the Minimal Theme (and I have the same trouble of a jumping Preview pane when previewing the theme).

Well, I disabled the CSS Snippet for the relationship lines in Preview Mode (:cry:).

And as for the rest, it’s still the same except that there was an update of Big Sur so I’m now on macOS Big Sur Version 11.2.2.

1 Like