iOS Scrolling Problem with external mouse (both mobile app and publish)

I’m having the same issue, not scrolling in that Obsidian home page and also in Obsidian.
It happens both in edit mode and reading mode, though never both at the same time: sometimes I can scroll in edit mode but not in reading mode and sometimes the opposite.
This happens with an external mouse and also with the integrated touchpad of the Logitech Combo Touch keyboard.

iPad Pro 11" 2020, iPadOS 17.3.1
Obsidian 1.4.16 (114)

1 Like

I experienced the same problem, but it seems to have been fixed in iPadOS 17.1.

iPadOS 16.6.1
Using an external mouse (Apple Magic Mouse)

Sometimes the scroll is smooth in Obsidian, but it frequently becomes sporadic and unusable. After repeated switching between reading/editing modes it sometimes becomes useable again. however that only lasts a little bit.

This has not been an issue previously for me (I’ve been using this specific setup for the past 2 weeks and have had no scrolling issues despite heavy usage.)

I recorded a video of the behavior but the forum does not allow me to post it.

Scrolling works perfectly fine in every other app and in Safari (with the exception to Obsidian Publish pages, as others have noted).

I will be updating to iPadOS 17 tonight to see if there is a change. I’m really curious why this effects both Obsidian and Obsidian Publish.

1 Like

That’s strange. I have ipadOS 17.1 too, but the issue persists all the same for me. It’s very limiting for my whole mobile workflow.

1 Like

100% - this kills my workflow when trying to use my iPad, which really sucks because I am trying to move to that as my primary mobile device outside of my phone.

4 Likes

any solutions to this yet ?
thanks

1 Like

I am also having the same problem. Scrolling on the external mouse works sometimes but not others. I notice it stops working on the settings menu most of the time.

I’m experiencing pretty laggy scrolling on my iPhone with just the touchscreen. I feel like i tried everything as its really distracting when im lookin through my notes. It seems to happen more in large notes, but at some level in all my notes.

Heres my debug info:


SYSTEM INFO:
Operating system: ios 17.2.1 (Apple iPhone)
Obsidian version: 1.4.16 (114)
API version: v1.4.16
Login status: logged in
Catalyst license: none
Live preview: on
Legacy editor: off
Base theme: adapt to system
Community theme: Atom v0.0.0
Snippets enabled: 0
Restricted mode: off
Plugins installed: 19
Plugins enabled: 8
1: Excalidraw v2.0.14
2: Kanban v1.5.3
3: Footnote Shortcut v0.1.3
4: Underline v1.2.1
5: Colored Tags v4.0.0
6: Better Word Count v0.10.0
7: Copy Block Link v1.0.4
8: LanguageTool Integration v0.3.6

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


I have tried browsing in restricted mode, moving my vault to a local folder on my phone, removing attachments, changing theme, etc.

It doesn’t happen at all on my mac.

I am on an iPad Pro 12.9” with iPadOS 17.3 installed. I also use a Logitech MX Master 3 mouse and scrolling (using the mouse wheel) works in the files and folders panel but not in a note body.

If I do nothing else but connect my Magic TrackPad scrolling works, but not with the Magic Mouse.

Making the app very hard to use for me as a lot of my notes are long.

Just noticed when I first open Obsidian, the note on screen scrolls fine, will note when it stops.

For me it doesn’t really matter what kind of “mouse” I connect to iPad (iPadOS 17.3).

It’s laggy with Magic Mouse / Magic Trackpad / 3rd party etui with keyboard and trackpad (ESR) / Logitech MX Ergo - for all of them the scroll tends to “jump up” on a larger notes.

@lesiu Could you elaborate “laggy”?

The issue I’m facing is that scrolling stops completely when I have my fingers on the touchpad. The page moves only when I let them go.

for example scrolling dow tends to “jump” back up to a certain height, making it really hard to just simply scroll down to the bottom of the file.

and this as some people stated here, does not happen if I have a “read” mode enabled. but as soon as I use live-preview, the scrolling gets funky. This does not happen when I’m using a finger - even with mouse/trackpad connected.

I am doing some research on this and this seems to be an iOS/Safari bug that landed sometimes in iOS 16. Other users report that trackpad/mouse scrolling sporadically doesn’t work on random websites and web-based apps. Sometimes it magically works again and sometimes it goes back to not working.

https://www.reddit.com/r/ipad/comments/1264qls/bug_with_smooth_scrolling_trackpad_on_safari/

If anyone knows more about what might cause something like this to happen I’d be happy to investigate more.

1 Like

I am having the same issue. Scroll doesn’t work when on the iPad Obsidian App. Using a 3rd party bluetooth mouse with 2 buttons and a scroll wheel. (Scroll works fine in other apps)

(post deleted by author)

Sorry for triggering a notification to anyone here again, but I realised that with my previous post I leaked my name :person_facepalming:

I thought I saw a comment stating this recently, but it seems like it got deleted (not sure why)

But today I realized that in some cases the scrolling bugs into a behavior where sliding fingers on the trackpad does nothing, but as soon as I raise them into some direction, the scroll starts moving. So, it doesn’t move when my fingers are on it. But it’s not always like that.

And I never experienced this in any website in Safari, yet I use iPad for web browsing for more than a year.

Sharing video of this behaviour in action in settings: Watch IMG_5434 | Streamable