iOS Scrolling Problem with external mouse (both mobile app and publish)

And will you be testing?

1 Like

This is not only occurring in safari. It is occurring in the Obsidian iOS app. When a note is in edit mode no scrolling with external mouse. When the note is in reading mode scrolling works.

I have the same problem, almost every time I use obsidian.

IPadOS 16.5
Using Apple’s external Magic Mouse, or trackpad on Magic Keyboard for iPad Pro.

I think I am having the same issue.

Greetings, I primarily use Obsidian on my iPad Pro. Previously on a note I was able to scroll up and down using the scroll wheel of my Bluetooth mouse. For that last week I have been unable to do this, I can only scroll up and down by using the touch interface. Has anyone else had this issue? Is there a fix for it?

What I’m trying to do

Scroll through a note on the iPad Pro using scroll wheel on Bluetooth mouse.

Things I have tried

iPadOS up to date. Completely disconnecting and re pairing mouse. Restarting iPad Pro.

Satachi M1 Mouse
IPad Pro 11”
iPadOS 16.5.1

Could take a screen video but it would simply be the page not scrolling while using the scroll wheel on my mouse.

Does th scroll wheel work on safari on this website?

I am unable to scroll in both reading AND edit mode.
This not being able to scroll on ipad might be a deal breaker for me. I don’t use a laptop and not being able to scroll through a note with a mouse is must have.

The scroll does not work on the main portion of that website in safari on the ipad. The scroll wheel works on the pane on the left but in the middle portion i cannot scroll via the scroll wheel on my Bluetooth mouse.

Same issue.
I use iPad pro 11’’ with Magic Keyboard trackpad. Scroll wheel doesn’t work on both Obsidian app and Obsidian Help website on Safari.

Seems to have been corrected either with the recent release of iPadOS17 Beta 6 OR latest release of Obsidian Mobile (8/30/2023). I’ll take either case! :clap:


Same issue. iPad Pro M2. Scrolling is fine initially, but when I open a side by side pdf, it gets buggy and doesn’t scroll well.

Let us know if this is fixed with ios17 once released.

I am having this same issue on iOS 17 Beta. I am using the 2021 iPad Magic keyboard. The scrolling only kicks in when I release my fingers from the trackpad. If I try to trackpad scroll and my fingers are in contact with the trackpad, nothing happens. As soon as my fingers are no longer touching the iPad, the scrolling works.

Do we have any updates on this regarding specifically scrolling with the mouse (not trackpad) on iOS app and iOS publish?

iPadOS 17, Obsidian 1.4.8, with bluetooth mouse, still the same problem (both APP and published sites, e.g. Obsidian help site)

Still erratic at best with latest iPadOS17 release. No noticeable improvement. :cry:

Additional followup - I’m having NO issues using the same set up with Obsidian Desktop, with the latest MacOS on my new M1 MacBook Air. FWIW.


I’m using a logitech MX Master 3 with an iPad 12.9" Wifi 256GB via bluetooth.

I haven’t attempted to scroll on any obsidian publish pages but the app is very buggy when it comes to scrolling. iOS 17.0.2 (updated since my post and it is still happening on the insider build).

1 Like

I have same problem. All side bars, scroll in working, but in note file, it is not. I can accidently fix it by turn on/off several times the edit/reading mode. Suddenly, the scroll works as normal now

1 Like

iPadOS 17.1 beta 3, Obsidian 1.4.8 (107)

Same behavior as @lohi. If I turn on-and-off the edit mode, then it works. It works fine in general Safari, though I don’t have Obsidian publish.