iOS app very slow moving from search, when a note is selected, to opening the note

My Obsidian on iOS (iPhone 14 Pro) has started running very slow. In particular, I notice it when I search for a file, click on it, then have to wait to be able to move to the note.

There’s also other situations on which it gets slow… e.g.

  • Moving between edit / reading mode
  • Clicking on a link and moving to that note (with this, the title switches rapidly, but the note content lags badly before appearing)
  • The command palette seems to randomly pop up while opening notes, and then takes forever to leave

Might be worth noting, that when I click the note to move to in the search bar, that the note actually seems to open quickly (you can see the text change in the small area to the right)… it’s moving the search bar aside that seems to take forever.

Would appreciate any advice! Thanks

Things I have tried

  • I have not, nor did I previously, have any community plugins installed
  • Restricted mode is on
  • I have no CSS snippets

I’d try restarting the phone.

1 Like

Tried that, hasn’t helped.

That said, it’s still very slow going from search → note, but the edit/read button isn’t lagging on the notes I’ve just checked.

Following links within notes is still generally very slow. I should probably note that some of them do go quickly… doesn’t seem to be any logic to this (big note / small note).

Hmm, strange. All I can think to suggest is to search here for posts about similar problems.

I use a JB device so a restart entails having to re-jailbreak again (extra work), but I found this course of action beneficial as well.

Is there no way to do a performance snapshot on an iPhone? Some way we can figure out what process is causing this? I’m a coder so am happy to dig in, because this is totally disabling. I just cannot use the app on my phone. Have tried searching but cannot find anything relevant, just some stuff about using a seperate keyboard.

Do the notes in question have HTML, GIFs, or embedded searches in them?

It seems to affect all notes, including very simple ones with just a few words.

I’ve just tried to create a new vault and it seems to work very fast with that.

I should note that the vault which is playing up is very large (9496 files), containing many images etc.

I’m a little confused. Did you mean earlier that any given note might go quickly or slowly at different times?

I don’t think this alone should cause that behavior. My vault reached >8,000 notes on an iPhone 13 (non-Pro) and the only slowness was at startup (4–5 seconds). I don’t have lots of images but that would if anything hurt my speed because Obsidian tracks less info about images than it does about notes. Sometimes searches aren’t instant, but there’s no lag when I click the results.

Are you results before the search has finished? (I don’t know if that would matter; I’d guess no.)

Sorry, wrote that badly. Was still (and am still) trying to be systematic about noticing what was wrong when I initially wrote hte post.

The search is always slow. I would say that everything else is also slow. It is not affected by which note it is.

I would also note, that it is not just search, it occurs when I try to open a file from the “Files” list.

I’m not actually sure the that edit/read button triggers it… think that might have just been me pressing it after triggering the lag through some other behaviour.

The best angle of attack here IMHO, is figuring out why opening a note is lagging. This is 100% reproducible. Is there any way to debug it?

I have been trying for a long time to streamline a workable experience on i(Pad)OS with a large-ish vault. I sort of have managed it, although lags crop up now and again. Apart from 1) restarting device 2) delete cache (on JB device) or delete app as in uninstall and reinstall with vault backed up 3) pinpoint which core or community plugin might be responsible (try deactivating a couple of core plugins as well), I can offer the following I wrote about these things:

There are other ways (like on this thread, for instance, but I wouldn’t recommend it too much) as well.

I use about 10-30 community plugins as well; 10 as in absolute must and I have 2 other config folders for mobile I can switch to (“relaunch as”) at a push – and of course all this is testing the waters rather than me knowing any of the rest of the 10-20 plugins are responsible for any lag.

What I found is that lag usually happens through accumulation as in daily usage (which is why restarts and cache deletions can have a refreshening effect) and by searching and caching in a large vault – in my case the large vault would amount to some 50-55MB in md files across 13500 files and that alone should not be a problem…
I started using ripgrep searches through iOS Shortcuts to not have Obsidian cache in the contents of all files but that’s about 5-6 times slower (35-45 secs compared to 6-7 secs in Obsidian) and not everyone is comfortable with terminal/JB hacks.

One thing is for sure: it is not about the performance or RAM of the device, but the handling of data, but I haven’t been able to pinpoint the exact issue. Too many inlinks (I have 150000)? Too many folders too deep? Diacritic characters galore? I’ll stop here…

1 Like


I deleted the app, then reinstalled and re-sync’d all my notes. This seems to have solved the problem.

A side note: I tried deleting the cache for Obsidian following this guide (How To Clear App Cache on iPhone: A Step-by-Step Guide | Capterra). iOS actually crashed when I tried to select Obsidian.

Oh. I’m not familiar with what iOS cache purging does with Obsidian. Never tried that. I was talking about deleting some folders in a jailbroken environment.

Hopefully, it’ll stay that way…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.